Visual Studio Ide for Arduino
https://www.visualmicro.com/forums/YaBB.pl
Other >> Arduino for Visual Studio 2010 >> Cannot create new arduino project
https://www.visualmicro.com/forums/YaBB.pl?num=1416743813

Message started by nspk on Nov 23rd, 2014 at 11:56am

Title: Cannot create new arduino project
Post by nspk on Nov 23rd, 2014 at 11:56am
Hello Guys,
   this is my first post, so I want to say helllo for everyone at first :).

Other thing is that i cannot create new arduino projcet in VS comunity edition after instalaiot visual micro - there are not position's in creation menu.

Other thing - before instalation Comunity edition i have got express edition isntalled - maybe it is connected with that?

Title: Re: Cannot create new arduino project
Post by Tineler on Nov 26th, 2014 at 10:07pm
I have the same problem even with Visual Studio 2013 Ultimate Edition...

Title: Re: Cannot create new arduino project
Post by Visual Micro on Nov 26th, 2014 at 11:11pm
Hi thanks for the tip about express we know this has happened for some users but not what might cause the change to the vs UI.

One other question is "when you first setup visual studio which layout did you pick?", general developement or web development or c# or c++ etc?

What has happened is that you have a "reduced" simpler visual studio layout. Normally you will find the "File" menu has a "New" sub menu with lots of options. this is where visual micro currently put "New Sketch Project" and the same for the "Open" menu so we get "File>Open>Sketch project".

In your versions of visual studio I don't think you have "File>New" instead will see the individual options directly on the file menu such as "File>New Project"

The result of not being able to locate the menus is that visual micro was unable to locate the "New" or "Open" menus and therefore failed to add the commands.

You can add them yourself because all visual micro commands are available as macros. Use "Tools>Customise>Commands>Menu Bar>File" and then click the "Add Command" button. You will find all the visual micro commands under the Addins section. The commands ones on the file menu have icons so should be relatively easy to spot. If you see a couple of duplicates the probably do the same thing.

OR

You can experiment with the different layouts. I find the general development layout to be good.

You can choose this collection of settings the first time you start Visual Studio. After that you can choose it by means of the Import and Export Settings command on the Tools menu.

[list bull-blueball]
  • On the first page of the wizard, pick Reset All Settings, then click Next.
  • Click Next again.
  • On the Choose a Default Collection of Settings page of the wizard, select General Development Settings.


    http://msdn.microsoft.com/en-us/library/vstudio/ms165473%28v=vs.100%29.aspx

    note: if you switch layout so you have a "file>new" then you can add missing items by clicking "tools>visual micro>reset user interface". visual micro will restart vs and re-create the visual micro ui elements. doing so will remove any visual micro menu and toolbar items that you have added yourself.

  • Title: Re: Cannot create new arduino project
    Post by unmateria on Jan 30th, 2015 at 9:06pm
    Hi Tim :)

    After some days trying things and your support. I uninstalled completely VS2008, 2010 and 2013 community (years of development on the same machine) and it didnt worked but finally, I solved the same problem as nspk (following your directions) doing exactly this:

    Tools -> Import and Export Settings
    Reset All Settings
    General Development Settings.
    Restart VS2013 community
    Tools -> visual micro -> Reset UI
    It will Restart VS2013 community

    :) Thanks for all and your good support. Lets try the IDE and buy it :)

    Visual Studio Ide for Arduino » Powered by YaBB 2.5.2!
    YaBB Forum Software © 2000-2019. All Rights Reserved.