Visual Studio Ide for Arduino
https://www.visualmicro.com/forums/YaBB.pl
>> >> Re: Intellisense doesn't work (RefreshIntellisense KeyNotFoundExeption The given key was not present in)
https://www.visualmicro.com/forums/YaBB.pl?num=1437633772

Message started by vlkam on Jul 23rd, 2015 at 10:10pm

Title: Re: Intellisense doesn't work (RefreshIntellisense KeyNotFoundExeption The given key was not present in)
Post by vlkam on Jul 23rd, 2015 at 10:10pm

Visual Micro wrote on Jul 23rd, 2015 at 12:34pm:
Which version of the arduino ide do you have installed?


Thanks for your answer
I have installed 1.0.4 and 1.6.3 versions of Arduino

Here is a little video (3.6 mb, 1 min) from my screen
http://screencast.com/t/Zb3NuHQ3DyV

Title: Re: Intellisense doesn't work (RefreshIntellisense KeyNotFoundExeption The given key was not present in)
Post by Visual Micro on Jul 23rd, 2015 at 10:42pm
Which version of the arduino ide do you have installed?

Title: Re: Intellisense doesn't work (RefreshIntellisense KeyNotFoundExeption The given key was not present in)
Post by Visual Micro on Jul 23rd, 2015 at 10:45pm
Hello, sorry I didn't see behind your image, the code editor also has no color :)

This was mentioned as an install problem in our FAQ but a new version was issued today that automatically ensures the color syntax and intellisense are registered with visual studio each time it starts.

Please either follow point 2 of the faq or install the latest release of visual micro
faq


EDIT

Can you also please re-select your board by changing to a different board and back again. If the intellisense error continues then please confirm you have color syntax code and switch on "tools>visual micro>user interface trace".


Thanks


ps: I deleted a couple of messages by mistake  :-[

Title: Re: Intellisense doesn't work (RefreshIntellisense KeyNotFoundExeption The given key was not present in)
Post by vlkam on Jul 24th, 2015 at 11:56am

Thanks a lot!  I'm so sorry for I didn't see this in Faq

Title: Re: Intellisense doesn't work (RefreshIntellisense KeyNotFoundExeption The given key was not present in)
Post by Visual Micro on Jul 24th, 2015 at 11:59am
No problem it's only been added in the last few days.. Thanks for letting me know it is OK

Visual Studio Ide for Arduino » Powered by YaBB 2.5.2!
YaBB Forum Software © 2000-2019. All Rights Reserved.