Visual Studio Ide for Arduino
https://www.visualmicro.com/forums/YaBB.pl
Other >> Other Hardware >> ATTinyCore install breaks VM
https://www.visualmicro.com/forums/YaBB.pl?num=1463298707

Message started by Trek19 on May 15th, 2016 at 8:51am

Title: ATTinyCore install breaks VM
Post by Trek19 on May 15th, 2016 at 8:51am
I installed the ATTiny cores fromhttps://github.com/SpenceKonde/ATTinyCore and all worked well within Arduino 1.6.9 but when I switchd to Visual Micro 1605.12.0 in Visual Studio 2014 I now get build errors for everything even the straightforward Arduino boards and cannot now use VM.
As a test I started a new blank Arduino project in VM and selected Arduinio/Genuino Uno. I also made sure no ATTinys were installed from Board manager and I made the \Documents\Arduino\hardware folder ZZZZhardware to stop its use but when I build I get:

[code]Compiling 'jimstest1' for 'Arduino/Genuino Uno'
Build folder: file:///C:/Users/Jim/AppData/Local/Temp/VMicroBuilds/jimstest1/uno
Summary: Header=1 Prototypes=3 Imports=0
Additional Defines:
Architecture Tools: C:\Users\Jim\AppData\Local\arduino15\packages\ATTinyCore\tools\avr-gcc\4.8.1-arduino5/bin/
Sketchbook: file:\\\C:\Users\Jim\Documents\Arduino
Sketch Include Paths
Include Path 'C:\Users\Jim\Documents\Arduino\jimstest1'
Core Include Paths
Include Path 'C:\Program Files\Arduino\hardware\arduino\avr\cores\arduino'
Include Path 'C:\Program Files\Arduino\hardware\arduino\avr\variants\standard'
Build Core Paths: C:\Program Files\Arduino\hardware\arduino\avr\cores\arduino
"C:\Users\Jim\AppData\Local\arduino15\packages\ATTinyCore\tools\avr-gcc\4.8.1-arduino5/bin/avr-gcc" -c -g -x assembler-with-cpp -mmcu=atmega328p -DF_CPU=16000000L -DARDUINO=10609 -DARDUINO_AVR_UNO -DARDUINO_ARCH_AVR -I"C:\Program Files\Arduino\hardware\arduino\avr\cores\arduino" -I"C:\Program Files\Arduino\hardware\arduino\avr\variants\standard" "C:\Program Files\Arduino\hardware\arduino\avr\cores\arduino\wiring_pulse.S" -o "C:\Users\Jim\AppData\Local\Temp\VMicroBuilds\jimstest1\uno\core\wiring_pulse.S.o" 
error*:CreateProcess: No such file or directory
Error compiling core[/code]

Obviously the reference to packages\ATTinyCore shouldnt be there.

SpenceKonde, the developer replied:
It sure looks like you have installed a tiny core through board manager? And also, it looks like it's trying to use the default core and the attiny core.

I think this is a visualmicro bug - the Arduino team keeps mucking with the spec for third party hardware packages, so it's entirely possible that they updated it to work with an early 1.6.x version - but the spec has changed in mutually incompatible ways a few times since.. so it wouldn't be surprising if visualmicro was incompatible with it.

I'm not familiar with visualmicro - but if you want to make a new issue to track progress trying to figure out how to make it work with visualmicro, but I can't really put time into getting these sorted out.

Any suggestions

Title: Re: ATTinyCore install breaks VM
Post by Visual Micro on May 15th, 2016 at 9:44pm
I suspect that you previously had used board manager to install a tiny core then uninstalled. That the tools folder exists for the install but is empty and that Visual Micro needs to test for invalid folders.

Delete this folder which is where the board manager installed to previously.

C:\Users\Jim\AppData\Local\arduino15\packages\ATTinyCore

Then restart the ide and see if that fixes it.

You are right it will be affecting all avr boards.

Title: Re: ATTinyCore install breaks VM
Post by Trek19 on May 17th, 2016 at 8:40am
Ok, as well as making \Documents\Arduino\hardware folder ZZZZhardware I made folder C:\Users\Jim\AppData\Local\AAarduino15 to stop their use and in VM did a "Tools - Visual Micro - Reload Toolchains" and then everthging worked OK for the UNO etc.
I then enabled the ATTiny cores in C:\Users\Jim\Documents\Arduino\hardware and again Reloaded the Toolchains and was able to use the cores in VM.
It appears that un-installing cores using Board Manager leaves some remnants behind in C:\Users\Jim\AppData\Local\arduino15\packages\ which the Arduino ide can ignore but VM cannot.
The reference to the cores - enabled or not - has been visible in my Board Manager for a long time but I have not noticed this effect before but coincidently I just updated both the Arduino ide and VM prior to this.
I am not sure where the problem is but it looks like its in VM.

Title: Re: ATTinyCore install breaks VM
Post by Visual Micro on May 18th, 2016 at 5:28pm
Thanks, yes I agree and I will change visual micro to ignore tools folders if they are empty.

Visual Studio Ide for Arduino » Powered by YaBB 2.5.2!
YaBB Forum Software © 2000-2019. All Rights Reserved.