Visual Studio Ide for Arduino
https://www.visualmicro.com/forums/YaBB.pl
>> >> Microsoft VSIX Installer fail
https://www.visualmicro.com/forums/YaBB.pl?num=1518192159

Message started by JohnF on Feb 9th, 2018 at 4:02pm

Title: Microsoft VSIX Installer fail
Post by JohnF on Feb 9th, 2018 at 4:02pm
Hi All,

I installed Atmel Studio 7 and attempted to install "Arduino IDE for Visual Studio and Atmel Studio"

The install failed.  I checked the log file and found

Searching for applicable products...
Found installed product - Global Location
Found installed product - AtmelStudio
VSIXInstaller.NoApplicableSKUsException: This extension is not installable on any currently installed products.

So it found Atmel Studio but failed anyway.

The The installation instruction make it sound easy.  How do I get past this?

Thank you,
https://www.visualmicro.com/forums/YaBB.pl?action=downloadfile;file=VSIXInstaller_9e70083a-b0cc-4e13-ba69-d887f69af7e5.txt (2 KB | )

Title: Re: Microsoft VSIX Installer fail
Post by Visual Micro on Feb 9th, 2018 at 4:51pm
When Microsoft released the VS shell that Atmel Studio uses they made a mistake with the installer version which affects users who have installed more recent versions of Visual Studio.

You need to install from within the Atmel IDE via Tools>Extensions and updates

Title: Re: Microsoft VSIX Installer fail
Post by JohnF on Feb 9th, 2018 at 6:26pm
That seemed to have worked!

Thank you,

-j

Visual Studio Ide for Arduino » Powered by YaBB 2.5.2!
YaBB Forum Software © 2000-2019. All Rights Reserved.