Visual Studio Ide for Arduino
https://www.visualmicro.com/forums/YaBB.pl
Visual Micro >> Atmel Studio 7.0 >> Tutorial and Step Debugging
https://www.visualmicro.com/forums/YaBB.pl?num=1525374545

Message started by AndyMM on May 3rd, 2018 at 8:09pm

Title: Tutorial and Step Debugging
Post by AndyMM on May 3rd, 2018 at 8:09pm
I am running my trial, I think. Honestly how can I even tell if I am running the evaluation version of Pro?  I am in tutorial mode and I'm trying to do this step by step as directed on the tutorial page but it is not working.

I seem to have everything squared away and I can follow all the way up until I load the blinkwithoutdelay program. I can tell it is loaded onto the board. It is indeed blinking. However the breakpoint isn't autoselected on loop despite tutorial being checked. Also when I try to run it on an additional program and try to debug I get a pop up saying "Please select a connected tool and interface and try again." Can someone tell me if I missed something?

Title: Re: Tutorial and Step Debugging
Post by Visual Micro on May 3rd, 2018 at 8:26pm
One example: When the trial or purchased license is enabled the options on the "vMicro>Debugger" menu are enabled. A project must be open to see the Debugger menu.

When Debug mode is enabled the build says " Compiling debug version of 'sketch name' for 'board name' "

When Release mode is enabled the build says "Compiling 'sketch name' for 'board name'"

By default the menu item "vMicro>Debugger>Automatic Debugging" is enabled which means that when you change the tool bar configuration name from "Release" to "Debug", the debugger will become active when you next build and upload.



note

If the above hints still do not allow debug to appear after upload then make sure you have not changed the global visual micro options called "Pause Pro Features". The option must be False which is the default. tools>options>visual micro>pause pro features


Title: Re: Tutorial and Step Debugging
Post by AndyMM on May 3rd, 2018 at 8:36pm
Well looks like everything is greyed out on that menu. How do I get back to the page where I initiate my trial version now that I've continued past that window?

Title: Re: Tutorial and Step Debugging
Post by Visual Micro on May 3rd, 2018 at 9:41pm
Is there a "vMicro>Try, Buy Activate" menu item?

Title: Re: Tutorial and Step Debugging
Post by AndyMM on May 3rd, 2018 at 9:51pm

Visual Micro wrote on May 3rd, 2018 at 9:41pm:
Is there a "vMicro>Try, Buy Activate" menu item?


I went into the vMicro>Debugger>and clicked Atmel Studio Debugger to remove the check mark and all the options became selectable. The breakpoint still doesnt appear in the tutorial mode but at least the functionality is there now.

Title: Re: Tutorial and Step Debugging
Post by Visual Micro on May 3rd, 2018 at 10:01pm
Yes if you had switched on atmel studio debugging then that overrides the usb/serial debug.

Is "vMicro>General>Tutorial Mode" enabled?




Title: Re: Tutorial and Step Debugging
Post by AndyMM on May 4th, 2018 at 12:58am

Visual Micro wrote on May 3rd, 2018 at 10:01pm:
Yes if you had switched on atmel studio debugging then that overrides the usb/serial debug.

Is "vMicro>General>Tutorial Mode" enabled?


It is enabled but it did not have the breakpoint preloaded as described. No matter however. I followed the examples and completed the first tutorial. I'm off to the races and debugging my own programs. Thanks for the quick responses though. I'm sure I'll be picking up the pro version as I'm getting tired of serial print debugging.

Title: Re: Tutorial and Step Debugging
Post by Visual Micro on May 11th, 2018 at 12:37am
Sorry forgot to add that means you had a break-point in another project in the solution (or one had been added automatically, it only adds one demo per solution when tutorials are enabled).

Visual Studio Ide for Arduino » Powered by YaBB 2.5.2!
YaBB Forum Software © 2000-2019. All Rights Reserved.