Visual Studio Ide for Arduino
https://www.visualmicro.com/forums/YaBB.pl
Visual Micro >> Atmel Studio 7.0 >> Uploading Bootloader MightyCore - Error: AVR Part "{build.mcu}" not found
https://www.visualmicro.com/forums/YaBB.pl?num=1531814931

Message started by vm24 on Jul 17th, 2018 at 9:08am

Title: Uploading Bootloader MightyCore - Error: AVR Part "{build.mcu}" not found
Post by vm24 on Jul 17th, 2018 at 9:08am
Hi all,
I'd like to programm a bootloader to AT1284p with Atmelstudio 7 and Visual Micro. Therfore I downloaded the Mighty Core Board Platform with the the Platform Installer of Arduino/ Visual Micro inside Atmelstudio 7.

When burning the Bootloader with vMicro > Uploader > Burn Bootloader I get this error meassage:


Code (]
Burning a new bootloader
Burning bootloader to board 'ATmega1284' using 'STK500 as ISP (MightyCore)'
Burn bootloader failed with an exception
     The uploader process failed

Error while burning bootloader.
avrdude: Version 6.3, compiled on Dec 16 2016 at 13:33:19
Burn failed
         Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/
         Copyright (c) 2007-2014 Joerg Wunsch
         System wide configuration file is "C:\Users\UserName\AppData\Local\arduino15\packages\MightyCore\hardware\avr\1.0.8/avrdude.conf"
avrdude: AVR Part "{build.mcu}" not found.
Valid parts are:
  m1284    = ATmega1284         [C:\Users\UserName\AppData\Local\arduino15\packages\MightyCore\hardware\avr\1.0.8/avrdude.conf:2506):

  m1284p   = ATmega1284P        [C:\Users\UserName\AppData\Local\arduino15\packages\MightyCore\hardware\avr\1.0.8/avrdude.conf:2314]
  m16      = ATmega16           [C:\Users\UserName\AppData\Local\arduino15\packages\MightyCore\hardware\avr\1.0.8/avrdude.conf:1303]
  m164a    = ATmega164A         [C:\Users\UserName\AppData\Local\arduino15\packages\MightyCore\hardware\avr\1.0.8/avrdude.conf:1864]
  m164p    = ATMEGA164P         [C:\Users\UserName\AppData\Local\arduino15\packages\MightyCore\hardware\avr\1.0.8/avrdude.conf:1674]
  m32      = ATmega32           [C:\Users\UserName\AppData\Local\arduino15\packages\MightyCore\hardware\avr\1.0.8/avrdude.conf:1487]
  m324a    = ATmega324A         [C:\Users\UserName\AppData\Local\arduino15\packages\MightyCore\hardware\avr\1.0.8/avrdude.conf:2089]
  m324p    = ATmega324P         [C:\Users\UserName\AppData\Local\arduino15\packages\MightyCore\hardware\avr\1.0.8/avrdude.conf:1881]
  m324pa   = ATmega324PA        [C:\Users\UserName\AppData\Local\arduino15\packages\MightyCore\hardware\avr\1.0.8/avrdude.conf:2073]
  m644     = ATmega644          [C:\Users\UserName\AppData\Local\arduino15\packages\MightyCore\hardware\avr\1.0.8/avrdude.conf:2106]
  m644p    = ATmega644P         [C:\Users\UserName\AppData\Local\arduino15\packages\MightyCore\hardware\avr\1.0.8/avrdude.conf:2297]
  m8535    = ATmega8535         [C:\Users\UserName\AppData\Local\arduino15\packages\MightyCore\hardware\avr\1.0.8/avrdude.conf:1139]

Title: Re: Uploading Bootloader MightyCore - Error: AVR Part "{build.mcu}" not found
Post by Visual Micro on Jul 18th, 2018 at 11:39pm
Hi

There is a fix for this in the visual studio version and the atmel version will follow over the next week or so.

https://www.visualmicro.com/forums/YaBB.pl?board=VS_ARDUINO_EXT_RELEASES

Thanks

Visual Studio Ide for Arduino » Powered by YaBB 2.5.2!
YaBB Forum Software © 2000-2020. All Rights Reserved.