Visual Micro Forum
https://www.visualmicro.com/forums/YaBB.pl
Visual Micro >> Arduino Usb/Serial/Udp Debugging >> Can not debug: error 'MicroDebug' was not declared in this scope
https://www.visualmicro.com/forums/YaBB.pl?num=1537611293

Message started by thisisjjwu on Sep 22nd, 2018 at 11:14am

Title: Can not debug: error 'MicroDebug' was not declared in this scope
Post by thisisjjwu on Sep 22nd, 2018 at 11:14am
     Hello, I just buy a Visual Micro Pro. License. When I build the code with release version. It  is correct, and can be downloaded to my uno board.

    But it shows 'MicroDebug' was not declared in this scope when I changed to debug build. So I can not enter the debug mode.

    My IDE is Microsoft Visual Studio 2017 Community. My Arduino IDE is 1.05-r2. I use Atmel Studio 2017 to do the same thing, it appeared  the same message, too.

    How can I do? Thank you~ ^_^
2.jpg (259 KB | )

Title: Re: Can not debug: error 'MicroDebug' was not declared in this scope
Post by thisisjjwu on Sep 22nd, 2018 at 12:38pm
I upgrade arduino  IDE to 1.86.
It can debug now! ^_^

Title: Re: Can not debug: error 'MicroDebug' was not declared in this scope
Post by Visual Micro on Sep 23rd, 2018 at 11:40am
Thanks for the report. Will fix the 1.x debugger for next release but upgrading is good too   :)

Title: Re: Can not debug: error 'MicroDebug' was not declared in this scope
Post by Visual Micro on Oct 4th, 2018 at 10:37pm
Fixed in 1810.03+

Visual Micro Forum » Powered by YaBB 2.5.2!
YaBB Forum Software © 2000-2020. All Rights Reserved.