Visual Studio Ide for Arduino
https://www.visualmicro.com/forums/YaBB.pl
Visual Micro >> Installation & Troubleshooting >> Visual Micro windows inside VS are not displaying anything
https://www.visualmicro.com/forums/YaBB.pl?num=1560170840

Message started by Davidos on Jun 10th, 2019 at 1:47pm

Title: Visual Micro windows inside VS are not displaying anything
Post by Davidos on Jun 10th, 2019 at 1:47pm
Hello, I have a problem with Visual Micro. I am using latest version of VS2019 (16.1.2) + latest VisualMicro (1906.3.0) + latest Windows update (1903) and I am facing issue which is showcased in the picture: https://i.imgur.com/3SYOEG2.png
I am here to ask you how to fix this problem.

Thanks,
David.

Title: Re: Visual Micro windows inside VS are not displaying anything
Post by Visual Micro on Jun 10th, 2019 at 1:58pm
Microsoft are messing with the tool windows so all extension authors with window forms tool windows are having to do a lot of workaround work.

Can you confirm this happens if you restart the ide? IE: doesn't just happen first time after install?

Can you also confirm the problem happens if you first wait for visual studio background tasks to complete before opening any tool windows. The background task icon bottom left of the ide shows when its finished?

If none of the above solves then switch off

Tools>options>environment>Optimize rendering for screens with different pixel densities. The restart the ide.
Thanks

Title: Re: Visual Micro windows inside VS are not displaying anything
Post by Davidos on Jun 10th, 2019 at 2:03pm
Well it turns out I was just too impatient. Waited for the background tasks to finish and it started working back again.
Thank you very much :)

Title: Re: Visual Micro windows inside VS are not displaying anything
Post by Visual Micro on Jun 10th, 2019 at 2:06pm
:) I've been trying to get Microsoft to fix it but they are so swamped with vs2019 bugs they don't believe it is unrelated to their new "Optimize rendering" scaling stuff. Sometimes they are really hard work.

Visual Studio Ide for Arduino » Powered by YaBB 2.5.2!
YaBB Forum Software © 2000-2019. All Rights Reserved.