Visual Studio Ide for Arduino
https://www.visualmicro.com/forums/YaBB.pl
Visual Micro >> Visual Studio 2017, 2019 >> Icons in Solution Explorer
https://www.visualmicro.com/forums/YaBB.pl?num=1564482258

Message started by G3WGV on Jul 30th, 2019 at 11:24am

Title: Icons in Solution Explorer
Post by G3WGV on Jul 30th, 2019 at 11:24am
When I add a new .ino file to a project it initially shows up in the Solution Explorer as an Arduino file (Arduino "infinity" icon). On subsequent startups of VS the files are sometimes but not always shown as C++ files (++ icon). I can't find any trigger for this apparently random behaviour.

It's no big deal of course and it may be nothing to do with VM. It would be interesting to understand what's going on.

John.
VM_003.png (54 KB | 0 )

Title: Re: Icons in Solution Explorer
Post by Visual Micro on Aug 3rd, 2019 at 6:04pm
Thanks for the post. What are you clicking when you add an .ino and which version of vs are you using?

Title: Re: Icons in Solution Explorer
Post by G3WGV on Aug 3rd, 2019 at 8:26pm
Hi Tim, thanks for the response.

I'm using VS 2019, although I saw the same behaviour when I was running VS 2015 until fairly recently. I click on the Add Code button in VS and then select the "Add empty Arduino .ino" option.

I should say that this really is no big deal, more of a curiosity really. It has no impact on functionality and I am a very contented (registered) user!

John.

Title: Re: Icons in Solution Explorer
Post by Visual Micro on Aug 3rd, 2019 at 8:31pm
Thanks, it's still interesting. Possibly a bug related to vs. I think you see the icon because the arduino ide associated it during the windows install. Why vs then loses it I will look at sometime out of interest.

Thanks again

Title: Re: Icons in Solution Explorer
Post by G3WGV on Aug 3rd, 2019 at 9:26pm

Thanks Tim. I agree, it looks like some sort of association problem but I've so far failed to find what triggers it.

I've been one of your happy band of users for some years now and the fact that this is the first time I have posted on the forum tells you that it's worked out well for me. You have a great product and I couldn't imagine going back to the Arduino IDE! Thank you!

John.

Title: Re: Icons in Solution Explorer
Post by Visual Micro on Aug 3rd, 2019 at 10:21pm
Thanks, I hope that continues for you.

If you find time to leave some stars in the gallery that would be appreciated. It's difficult to get any traction on google.

https://marketplace.visualstudio.com/items?itemName=VisualMicro.ArduinoIDEforVisualStudio&ssr=false#review-details

Thanks again.

Title: Re: Icons in Solution Explorer
Post by G3WGV on Aug 3rd, 2019 at 10:43pm
I already gave VM five stars on 8th June 2016 and mean old Microsoft won't let me post another review! My opinion hasn't changed though:

"Why did it take me so long to escape from the Arduino IDE to this vastly superior developer's environment? I am so impressed with this Visual Micro plug-in that I bought the Pro version well before the 45 day trial ran out.

"Anyone who uses this excellent product should support the author by paying for the Pro version. The support is excellent, it is not expensive and good software takes time and money to develop."

Thinks... I should send you some money for annual support. I didn't realise it was an option. [edit] Done!

Visual Studio Ide for Arduino » Powered by YaBB 2.5.2!
YaBB Forum Software © 2000-2019. All Rights Reserved.