Visual Micro
https://www.visualmicro.com/forums/YaBB.pl
Visual Micro >> Usb/Serial/WiFi Debugging >> Projects with debug option not working anymore.
https://www.visualmicro.com/forums/YaBB.pl?num=1589063565

Message started by JVM on May 9th, 2020 at 11:32pm

Title: Projects with debug option not working anymore.
Post by JVM on May 9th, 2020 at 11:32pm
projects with debug option not working anymore.

Release mode works fine. Nothing fancing. Arduino Nano thru USB.
could you help me?

https://www.visualmicro.com/forums/YaBB.pl?action=downloadfile;file=debug_fail.txt (0 KB | 14 )

Title: Re: Projects with debug option not working anymore.
Post by Visual Micro on May 10th, 2020 at 1:41pm
Please follow the guide in yellow above so that we can see your configuration.

The error can be caused by invalid breakpoint syntax but also other things, therefore we need that config info.

Thanks.

Title: Re: Projects with debug option not working anymore.
Post by JVM on May 10th, 2020 at 2:37pm
Here follows the log. I have gone thru the forum but no solution sims to work. Thank you.
https://www.visualmicro.com/forums/YaBB.pl?action=downloadfile;file=debug_fail_log.txt (3 KB | 12 )

Title: Re: Projects with debug option not working anymore.
Post by Visual Micro on May 10th, 2020 at 5:48pm
Please email or zip and attach this file

[code]C:\Users\Valeriano\AppData\Local\Temp\VMBuilds\Blink\nano_atmega328\Debug\Blink.cpp[/code]

Thanks

Title: Re: Projects with debug option not working anymore.
Post by Visual Micro on May 23rd, 2020 at 6:58pm
This issue is resolved in 20.05.18.5 available here https://www.visualmicro.com/forums/YaBB.pl?board=VS_ARDUINO_EXT_RELEASES

The issue happened in recent releases if "deep search for libraries" was switched off.

Thanks for the report.

Visual Micro » Powered by YaBB 2.5.2!
YaBB Forum Software © 2000-2021. All Rights Reserved.