Welcome, Guest. Please Login or Register
Arduino IDE for Visual Studio
 
 
When Logging a Support Issue in the Forum, please ensure you have also:-
  • Enabled vMicro > Compiler > Show Build Properties and Verbose
  • Re-Compile your program with these settings enabled
 
Save the new Output to a Text File and....
Support requests without the output above may be impossible to answer, so please help us to help you
 
  HomeSearch Tutorials & Wiki visualmicro.com LoginHelpRegister  
 
Page Index Toggle Pages: 1
Send Topic Print
Multiple New Installation Problems (Read 4724 times)
Matthew
Newbies
*
Offline



Posts: 2
Multiple New Installation Problems
Nov 14th, 2011 at 4:27pm
 
Good Day,

I have followed the installation guide for VisualMicro and also referenced sevelarl other posts attempting to understand my issues.  Perhaps someone is familiar with what I may have done incorrectly?

  • I downloaded and installed the arduino-0023 application and unzipped it into my Users/xxx/Documents folder.
  • I then ran the arduino.exe and opened a few sketches, saved them, then closed the application.
  • I have not connected an Arduino Microcontroller to the computer I am using as the hardware is at a different location than my VS2010 installation.
  • I then Installed the ArduinoForVisualStudio.msi application and adjusted my options.

When I create a new Arduino Project I get the message in vmicro_error1.jpg(? Can't Upload Pictures?).  I have not figured out what this is.

The text is Title: "Visual.Micro.Visual.Studio.Arduino.10"
Body: "Unable to create new sketch
Index was out of range. Must be non-negative and less than the size of the collection.
Parameter name: index"
Button: "OK"

When I attempt to add Arduino libraries by going to Project -> Add Arduino Library, the sub options of User and Core are grayed out as in picture vmicro_error2.jpg (? Can't Upload Pictures?).

I am including my Software Information at the bottom of this post that lists my installed software version just in case that helps.

Any Ideas?

Thanks,
Matthew

Code:
Microsoft Visual Studio 2010
Version 10.0.40219.1 SP1Rel
Microsoft .NET Framework
Version 4.0.30319 SP1Rel

Installed Version: Premium

Microsoft Office Developer Tools   01021-532-2002102-70409
Microsoft Office Developer Tools

Microsoft Visual Basic 2010   01021-532-2002102-70409
Microsoft Visual Basic 2010

Microsoft Visual C# 2010   01021-532-2002102-70409
Microsoft Visual C# 2010

Microsoft Visual C++ 2010   01021-532-2002102-70409
Microsoft Visual C++ 2010

Microsoft Visual F# 2010   01021-532-2002102-70409
Microsoft Visual F# 2010

Microsoft Visual Studio 2010 Code Analysis Spell Checker   01021-532-2002102-70409
Microsoft Visual Studio 2010 Code Analysis Spell Checker

Portions of International CorrectSpell™ spelling correction system © 1993 by Lernout & Hauspie Speech Products N.V. All rights reserved.

The American Heritage® Dictionary of the English Language, Third Edition Copyright © 1992 Houghton Mifflin Company. Electronic version licensed from Lernout & Hauspie Speech Products N.V. All rights reserved.

Microsoft Visual Studio 2010 Team Explorer   01021-532-2002102-70409
Microsoft Visual Studio 2010 Team Explorer

Microsoft Visual Web Developer 2010   01021-532-2002102-70409
Microsoft Visual Web Developer 2010

AnkhSVN - Subversion Support for Visual Studio   2.1.10129.17
AnkhSVN - Subversion Support for Visual Studio 2.1.10129.17
 * Ankh.Package 2.1.10129.17
 * Subversion 1.6.16 via SharpSvn 1.6016.1637.10768

SharpSvn is linked to: Apr 1.4.2, Apr-util 1.3.10, Neon 0.29.5, OpenSSL 1.0.0d 8 Feb 2011, serf 0.7.1, SQLite 3.7.5, Subversion 1.6.16-SharpSvn-tag-1.6.16@1076827, ZLib 1.2.5
SharpSvn is dynamically linked to: Cyrus Sasl 2.1.23
SharpSvn is optionally linked to: Berkeley DB 4.4.20, SharpPlink 1.6016.1637.10768

Crystal Reports Templates for Microsoft Visual Studio 2010   
Crystal Reports Templates for Microsoft Visual Studio 2010

Hotfix for Microsoft Visual Studio 2010 Premium - ENU (KB2542054)   KB2542054
This hotfix is for Microsoft Visual Studio 2010 Premium - ENU.
If you later install a more recent service pack, this hotfix will be uninstalled automatically.
For more information, visit http://support.microsoft.com/kb/2542054.

Microsoft Visual Studio 2010 Premium - ENU Service Pack 1 (KB983509)   KB983509
This service pack is for Microsoft Visual Studio 2010 Premium - ENU.
If you later install a more recent service pack, this service pack will be uninstalled automatically.
For more information, visit http://support.microsoft.com/kb/983509.

Microsoft Visual Studio 2010 SharePoint Developer Tools   10.0.40219
 

Back to top
« Last Edit: Nov 14th, 2011 at 4:28pm by Matthew »  
 
IP Logged
 
Visual Micro
Administrator
*****
Offline



Posts: 10631
United Kingdom
Re: Multiple New Installation Problems
Reply #1 - Nov 14th, 2011 at 4:41pm
 
have you set your arduino application (exe) path in the visual micro options?
Back to top
 

WWW  
IP Logged
 
Matthew
Newbies
*
Offline



Posts: 2
Re: Multiple New Installation Problems
Reply #2 - Nov 14th, 2011 at 4:47pm
 
Yes, I did set the Arduion Application path in the Tools/Options/Visual Micro section.

Also, I just performed the "How to reset the arduino visual studio interface" steps and that has taken care of the first error and the grayed out options in the Project -> Add Arduino Library section.  I can now choose things from under "Core".

Not sure what happened as I did not install the plugin until after I installed and ran the Arduino software.

Basically my problems are fixed.  Thanks for your help!  I did not run the reset earlier because I had not done what was said would cause me to need to perform the reset.  Sorry for wasting anyones time...

Oh, this is pretty cool and much nicer than using the Arduino Interface so far.  Smiley

Matthew
Back to top
 
 
IP Logged
 
Visual Micro
Administrator
*****
Offline



Posts: 10631
United Kingdom
Re: Multiple New Installation Problems
Reply #3 - Nov 14th, 2011 at 4:49pm
 
well done that man! visual studio does get it's knickers in a twist sometimes.

the next release drops the need for vb and maybe sorts the need for resetaddin

thanks for letting us know. enjoy!

ps: you did everything right
Back to top
« Last Edit: Nov 14th, 2011 at 4:51pm by Visual Micro »  

WWW  
IP Logged
 
Page Index Toggle Pages: 1
Send Topic Print