Welcome, Guest. Please Login or Register
Arduino IDE for Visual Studio
 
 
When Logging a Support Issue in the Forum, please ensure you have also:-
  • Enabled vMicro > Compiler > Show Build Properties and Verbose
  • Re-Compile your program with these settings enabled
 
Save the new Output to a Text File and....
Support requests without the output above may be impossible to answer, so please help us to help you
 
  HomeSearch Tutorials & Wiki visualmicro.com LoginHelpRegister  
 
Page Index Toggle Pages: 1
Send Topic Print
Re: Intellisense doesn't work (RefreshIntellisense KeyNotFoundExeption The given key was not present in) (Read 3945 times)
vlkam
Newbies
*
Offline



Posts: 2
Re: Intellisense doesn't work (RefreshIntellisense KeyNotFoundExeption The given key was not present in)
Jul 23rd, 2015 at 10:10pm
 
Visual Micro wrote on Jul 23rd, 2015 at 12:34pm:
Which version of the arduino ide do you have installed?


Thanks for your answer
I have installed 1.0.4 and 1.6.3 versions of Arduino

Here is a little video (3.6 mb, 1 min) from my screen
http://screencast.com/t/Zb3NuHQ3DyV
Back to top
 
 
IP Logged
 
Visual Micro
Administrator
*****
Offline



Posts: 10630
United Kingdom
Re: Intellisense doesn't work (RefreshIntellisense KeyNotFoundExeption The given key was not present in)
Reply #1 - Jul 23rd, 2015 at 10:42pm
 
Which version of the arduino ide do you have installed?
Back to top
 
WWW  
IP Logged
 
Visual Micro
Administrator
*****
Offline



Posts: 10630
United Kingdom
Re: Intellisense doesn't work (RefreshIntellisense KeyNotFoundExeption The given key was not present in)
Reply #2 - Jul 23rd, 2015 at 10:45pm
 
Hello, sorry I didn't see behind your image, the code editor also has no color Smiley

This was mentioned as an install problem in our FAQ but a new version was issued today that automatically ensures the color syntax and intellisense are registered with visual studio each time it starts.

Please either follow point 2 of the faq or install the latest release of visual micro
faq


EDIT

Can you also please re-select your board by changing to a different board and back again. If the intellisense error continues then please confirm you have color syntax code and switch on "tools>visual micro>user interface trace".


Thanks


ps: I deleted a couple of messages by mistake  Embarrassed
Back to top
« Last Edit: Jul 23rd, 2015 at 10:55pm by Visual Micro »  
WWW  
IP Logged
 
vlkam
Newbies
*
Offline



Posts: 2
Re: Intellisense doesn't work (RefreshIntellisense KeyNotFoundExeption The given key was not present in)
Reply #3 - Jul 24th, 2015 at 11:56am
 

Thanks a lot!  I'm so sorry for I didn't see this in Faq
Back to top
 
 
IP Logged
 
Visual Micro
Administrator
*****
Offline



Posts: 10630
United Kingdom
Re: Intellisense doesn't work (RefreshIntellisense KeyNotFoundExeption The given key was not present in)
Reply #4 - Jul 24th, 2015 at 11:59am
 
No problem it's only been added in the last few days.. Thanks for letting me know it is OK
Back to top
 
WWW  
IP Logged
 
Page Index Toggle Pages: 1
Send Topic Print