Welcome, Guest. Please Login or Register
Arduino IDE for Visual Studio
 
 
When Logging a Support Issue in the Forum, please ensure you have also:-
  • Enabled vMicro > Compiler > Show Build Properties and Verbose
  • Re-Compile your program with these settings enabled
 
Save the new Output to a Text File and....
Support requests without the output above may be impossible to answer, so please help us to help you
 
  HomeSearch Tutorials & Wiki visualmicro.com LoginHelpRegister  
 
Page Index Toggle Pages: 1
Send Topic Print
Problem after installing Arduino 1.6.6 (Read 5217 times)
Willem
Newbies
*
Offline



Posts: 8
Netherlands
Problem after installing Arduino 1.6.6
Nov 25th, 2015 at 1:56pm
 
Hello,

I installed Arduino version 1.6.6 and from this version I can edit/compile and download without any problem.
Before I used Arduino 1.6.5 with Visual Micro (VM version from last July and Visual Studio 2013) and it worked great.
But now after installation of Arduino version 1.6.6 used with VM I get this strange error:
----------------------------------------------------
Compiling 'Blink' for 'Arduino/Genuino Uno'
     Process: "{runtime.tools.avr-gcc.path}\bin\avr-g++" -c -g -Os -w -std=gnu++11 -fno-exceptions -ffunction-sections -fdata-sections -fno-threadsafe-statics -MMD -mmcu=atmega328p -DF_CPU=16000000L -DARDUINO=166 -DARDUINO_AVR_UNO -DARDUINO_ARCH_AVR -I"C:\Program Files\Arduino\hardware\arduino\avr\cores\arduino" -I"C:\Program Files\Arduino\hardware\arduino\avr\variants\standard" "C:\Users\WIEL ADMIN\AppData\Local\V.Micro\Arduino\Builds\Blink\uno\Blink.cpp" -o "C:\Users\WIEL ADMIN\AppData\Local\V.Micro\Arduino\Builds\Blink\uno\Blink.cpp.o"
Error compiling
-----------------------------------------------------------------

What am I doing wrong?
Many thanks in advance!!
Back to top
« Last Edit: Nov 25th, 2015 at 1:57pm by Willem »  
 
IP Logged
 
Visual Micro
Administrator
*****
Offline



Posts: 10563
United Kingdom
Re: Problem after installing Arduino 1.6.6
Reply #1 - Nov 25th, 2015 at 2:06pm
 
Hi,

When did you last upgrade visual micro?
Back to top
 
WWW  
IP Logged
 
Willem
Newbies
*
Offline



Posts: 8
Netherlands
Re: Problem after installing Arduino 1.6.6
Reply #2 - Nov 25th, 2015 at 5:00pm
 
Hi,

Last update (and first install) of Visual Micro was the July 2015 version.
Back to top
 
 
IP Logged
 
Visual Micro
Administrator
*****
Offline



Posts: 10563
United Kingdom
Re: Problem after installing Arduino 1.6.6
Reply #3 - Nov 25th, 2015 at 5:06pm
 
Hi,

Did you see any prompts notifying that a Visual Micro update available?

It's always best to ensure your Visual Micro version is more recent than the arduino version. 1.6.6 was only released recently.

You should also make sure you run any new arduino ide once so that it installs fully.

Thanks
Back to top
 
WWW  
IP Logged
 
Willem
Newbies
*
Offline



Posts: 8
Netherlands
Re: Problem after installing Arduino 1.6.6
Reply #4 - Nov 26th, 2015 at 6:13pm
 
Hello,

I updated Visual Micro and the problem is gone so all works fine.
Many thanks for your quick help!!

Greetings,
Willem
Back to top
 
 
IP Logged
 
Visual Micro
Administrator
*****
Offline



Posts: 10563
United Kingdom
Re: Problem after installing Arduino 1.6.6
Reply #5 - Feb 13th, 2017 at 11:25am
 
Off-Topic replies have been moved to this Topic.
Back to top
 
WWW  
IP Logged
 
Page Index Toggle Pages: 1
Send Topic Print