Welcome, Guest. Please Login or Register
Arduino IDE for Visual Studio
 
 
When Logging a Support Issue in the Forum, please ensure you have also:-
  • Enabled vMicro > Compiler > Show Build Properties and Verbose
  • Re-Compile your program with these settings enabled
 
Save the new Output to a Text File and....
Support requests without the output above may be impossible to answer, so please help us to help you
 
  HomeSearch Tutorials & Wiki visualmicro.com LoginHelpRegister  
 
Page Index Toggle Pages: 1
Send Topic Print
Lost intellisense functionality (Read 2067 times)
JoeMcC
Junior Member
**
Offline



Posts: 27
Lost intellisense functionality
Apr 19th, 2017 at 1:25pm
 
Hello All,
I seemed to have lost my intellisense functionality, or at least some of it. Now when i use uint8_t is doesnt itallic it and I can not go to "implementation" of whatever I right click on. Using Atmel Studio 7.

Is there a fix for this. Really like it.

Thanks
Back to top
 
 
IP Logged
 
Visual Micro
Administrator
*****
Offline



Posts: 10545
United Kingdom
Re: Lost intellisense functionality
Reply #1 - Apr 19th, 2017 at 1:44pm
 
Switch on vmicro>compiler>verbose and also the "show build properties" option

Then build and post the output as a .txt file.

Then we will see what hardware, ide and configuration you are using.
Back to top
 
WWW  
IP Logged
 
JoeMcC
Junior Member
**
Offline



Posts: 27
Re: Lost intellisense functionality
Reply #2 - Apr 19th, 2017 at 1:53pm
 
Thanks for the quick response Tim, the text file is attached.


Back to top
 

Build_003.txt (14 KB | )
 
IP Logged
 
JoeMcC
Junior Member
**
Offline



Posts: 27
Re: Lost intellisense functionality
Reply #3 - Apr 19th, 2017 at 2:28pm
 
I just noticed that a lot of updates have been made. I am using VS 1609 and the most current is 1703. You've been busy !

I will download that version and install and see if that helps.
Back to top
 
 
IP Logged
 
JoeMcC
Junior Member
**
Offline



Posts: 27
Re: Lost intellisense functionality
Reply #4 - Apr 19th, 2017 at 2:50pm
 
I guess I do not know the diff between intellisense and visual assist.

Downloaded latest update to VS and then enabled visual assist and got everything back the way it was.

What is the diff between the two ?
Back to top
 
 
IP Logged
 
Visual Micro
Administrator
*****
Offline



Posts: 10545
United Kingdom
Re: Lost intellisense functionality
Reply #5 - Apr 19th, 2017 at 3:01pm
 
Visual Assist is the intellisense system of Atmel Studio

Visual Micro simply provides paths to source code then leaves Visual Assist to do what it does

It's possible you installed a new arduino ide or tool chain. If that is true, Arduino have moved a lot of source code so you would need an updated visual micro to cater for that.

Alternatively if you had disabled visual assist then you would only see the basic visual studio intellisense which would be rubbish.

Hopefully this explains what happened, thanks for the update.
Back to top
« Last Edit: Apr 19th, 2017 at 3:02pm by Visual Micro »  
WWW  
IP Logged
 
Page Index Toggle Pages: 1
Send Topic Print