Welcome, Guest. Please Login or Register
Arduino IDE for Visual Studio
 
 
When Logging a Support Issue in the Forum, please ensure you have also:-
  • Enabled vMicro > Compiler > Show Build Properties and Verbose
  • Re-Compile your program with these settings enabled
 
Save the new Output to a Text File and....
Support requests without the output above may be impossible to answer, so please help us to help you
 
  HomeSearch Tutorials & Wiki visualmicro.com LoginHelpRegister  
 
Page Index Toggle Pages: 1
Send Topic Print
(Solved) Arduino pro micro serial port(in VS) not working (Read 1368 times)
Precious Roy
Newbies
*
Offline



Posts: 6
(Solved) Arduino pro micro serial port(in VS) not working
Jul 18th, 2018 at 11:43pm
 
Hello,

I am having issues wit the serial port in visual studio.

using a MEGA the serial port works fine but with both of my pro mico's i see no data in the serial port.

i tested it with the arduino editor and i get output data. so i was wondering if something is wrong with my setup.

Roy
Back to top
« Last Edit: Jul 19th, 2018 at 1:23pm by Precious Roy »  
 
IP Logged
 
Visual Micro
Administrator
*****
Offline



Posts: 10617
United Kingdom
Re: Arduino pro micro serial port(in VS) not working
Reply #1 - Jul 18th, 2018 at 11:44pm
 
what baud rate have you set?

is this with or without debug enabled?
Back to top
 
WWW  
IP Logged
 
Precious Roy
Newbies
*
Offline



Posts: 6
Re: Arduino pro micro serial port(in VS) not working
Reply #2 - Jul 19th, 2018 at 10:04am
 
this is without debug enabled, project is set to release.

Edit:
I noticed that the way it programs the micro is different. It seems to connect to a different serial port. i was wondering if the way the serial port works is also different than other arduinos.

Sketch uses 7642 bytes (26%) of program storage space. Maximum is 28672 bytes.
Global variables use 386 bytes (15%) of dynamic memory, leaving 2174 bytes for local variables. Maximum is 2560 bytes.
Forcing reset using 1200bps open/close on port COM4
PORTS {COM1, COM4, } / {COM1, } => {}
PORTS {COM1, } / {COM1, COM3, } => {COM3, }
Found upload port: COM3

COM4 was the port it is connected to
Back to top
« Last Edit: Jul 19th, 2018 at 11:16am by Precious Roy »  
 
IP Logged
 
Visual Micro
Administrator
*****
Offline



Posts: 10617
United Kingdom
Re: Arduino pro micro serial port(in VS) not working
Reply #3 - Jul 19th, 2018 at 11:19am
 
Hi,

Arduino does same for upload. Some boards are sent a reboot command then they boot onto different com port for upload.

Please answer question about the baud rate you are using in your code.
Back to top
 
WWW  
IP Logged
 
Precious Roy
Newbies
*
Offline



Posts: 6
Re: Arduino pro micro serial port(in VS) not working
Reply #4 - Jul 19th, 2018 at 12:09pm
 
So this code does not print out anything in VS serial window for the micro.


void setup() {
  Serial.begin(9600);
}

void loop() {
  Serial.println("Test");
}

It does however work for Mega
Back to top
 
 
IP Logged
 
Visual Micro
Administrator
*****
Offline



Posts: 10617
United Kingdom
Re: Arduino pro micro serial port(in VS) not working
Reply #5 - Jul 19th, 2018 at 12:16pm
 
Okay to confirm...

The toolbar says Release and not Debug?
The speed on the serial monitor shows 9600?
What usb device driver name and date shows in control panel > device manager for com4?

Thanks
Back to top
 
WWW  
IP Logged
 
Precious Roy
Newbies
*
Offline



Posts: 6
Re: Arduino pro micro serial port(in VS) not working
Reply #6 - Jul 19th, 2018 at 1:04pm
 
Ok I have been testing a lot, and it seems that i needed enable RTS. witch the mega does not need.

what does that setting do ?
Back to top
 
 
IP Logged
 
Visual Micro
Administrator
*****
Offline



Posts: 10617
United Kingdom
Re: Arduino pro micro serial port(in VS) not working
Reply #7 - Jul 19th, 2018 at 1:08pm
 
The default should be RTS on which is a serial ready To send flag.

Other boards such as Esp8266 and Esp32 have this setting off.

Normally Visual Micro handles automatically so it should have been On. If you didn't change it I will check the default.

Thanks
Back to top
 
WWW  
IP Logged
 
Precious Roy
Newbies
*
Offline



Posts: 6
Re: Arduino pro micro serial port(in VS) not working
Reply #8 - Jul 19th, 2018 at 1:22pm
 
I dont remember changing it. do it default with a new project ?
if so then it is probably set wrong.

Thanks for trying to help i appropriate it!
Back to top
« Last Edit: Jul 19th, 2018 at 1:23pm by Precious Roy »  
 
IP Logged
 
Page Index Toggle Pages: 1
Send Topic Print