Welcome, Guest. Please Login or Register
Arduino IDE for Visual Studio
 
 
When Logging a Support Issue in the Forum, please ensure you have also:-
  • Enabled vMicro > Compiler > Show Build Properties and Verbose
  • Re-Compile your program with these settings enabled
 
Save the new Output to a Text File and....
Support requests without the output above may be impossible to answer, so please help us to help you
 
  HomeSearch Tutorials & Wiki visualmicro.com LoginHelpRegister  
 
Pages: 1 2 
Send Topic Print
Breakpoints hitting in main sketch, but not in user library (Read 2852 times)
Visual Micro
Administrator
*****
Offline



Posts: 10563
United Kingdom
Re: Breakpoints hitting in main sketch, but not in user library
Reply #20 - Nov 17th, 2018 at 8:21pm
 
The interim release was going to be a few days and yes that is an image for the new feature in the next release

You can download from the most recent post titled "work in progress" from here Visual Micro Interim Releases and Notifications
Back to top
« Last Edit: Nov 17th, 2018 at 8:22pm by Visual Micro »  
WWW  
IP Logged
 
gj
Junior Member
**
Offline


Assumption is the mother
of all f*ckups

Posts: 35
Re: Breakpoints hitting in main sketch, but not in user library
Reply #21 - Nov 17th, 2018 at 8:49pm
 
Yes! That did the trick.

I downloaded the work-in-progress-version 1811.17 and installed it.
Triggers are now also fired in the library.  Smiley

Thanks for your great support!
Back to top
 
 
IP Logged
 
Visual Micro
Administrator
*****
Offline



Posts: 10563
United Kingdom
Re: Breakpoints hitting in main sketch, but not in user library
Reply #22 - Nov 17th, 2018 at 9:27pm
 
Thanks, I'm not sure the  shared library projects are working entirely right. There might be another release. If it builds for you that is fine.
Back to top
 
WWW  
IP Logged
 
Pages: 1 2 
Send Topic Print