Welcome, Guest. Please Login or Register
Arduino IDE for Visual Studio
 
 
When Logging a Support Issue in the Forum, please ensure you have also:-
  • Enabled vMicro > Compiler > Show Build Properties and Verbose
  • Re-Compile your program with these settings enabled
 
Save the new Output to a Text File and....
Support requests without the output above may be impossible to answer, so please help us to help you
 
  HomeSearch Tutorials & Wiki visualmicro.com LoginHelpRegister  
 
Page Index Toggle Pages: 1
Send Topic Print
Problems in Vs2017 (Read 481 times)
Hoss
Newbies
*
Offline



Posts: 4
Problems in Vs2017
Feb 10th, 2019 at 2:27pm
 
Has anyone had problems in VS2017?
I dont know if this is me being stupid or a bug.

I used Vs2015 for some years, then upgraded to 2017, then didnt code for about a year, so forgot if it was working before of not.
The problems i have:
- Visual Micro Explorer does not open after selecting
- Serial monitor does not open
Back to top
 
 
IP Logged
 
Visual Micro
Administrator
*****
Offline



Posts: 10339
United Kingdom
Re: Problems in Vs2017
Reply #1 - Feb 10th, 2019 at 2:43pm
 
Hi

This isn't a known issue. The fact that both the monitor and the explorer both reply on visual studio tool windows suggests that the visual studio installation is not entirely happy. I would suggest running a repair on Visual Studio via "Control panel >Add or Remove > Visual Studio 2017 > Change"
Back to top
 
WWW  
IP Logged
 
Hoss
Newbies
*
Offline



Posts: 4
Re: Problems in Vs2017
Reply #2 - Feb 10th, 2019 at 2:52pm
 
I made an update which went cleanly, no change

I'm just reinstalling 2015 to see if that works.
Back to top
 
 
IP Logged
 
Visual Micro
Administrator
*****
Offline



Posts: 10339
United Kingdom
Re: Problems in Vs2017
Reply #3 - Feb 10th, 2019 at 3:12pm
 
It's unclear if you have both 2015 and 2017 installed or not. They can be installed side by side, are two different IDE's. It is also unclear if the issue is in vs2017 or vs2015 but Visual Micro will also be installed separately for each IDE. This is how VS works with extensions.

I suggest you use tools>extensions inside the IDE to uninstall/remove visual micro. Then use the same to install visual micro again. Hopefully that sorts out the issue.
Back to top
 
WWW  
IP Logged
 
Hoss
Newbies
*
Offline



Posts: 4
Re: Problems in Vs2017
Reply #4 - Feb 10th, 2019 at 3:39pm
 
Haha ok solved, i was being stupid. The windows were opening on my 2nd monitor which was switched to a different input.
Back to top
 
 
IP Logged
 
Visual Micro
Administrator
*****
Offline



Posts: 10339
United Kingdom
Re: Problems in Vs2017
Reply #5 - Feb 10th, 2019 at 3:42pm
 
Great, that's the best reason Smiley

Thanks for the update
Back to top
 
WWW  
IP Logged
 
Page Index Toggle Pages: 1
Send Topic Print