Welcome, Guest. Please Login or Register
Arduino IDE for Visual Studio
 
 
When Logging a Support Issue in the Forum, please ensure you have also:-
  • Enabled vMicro > Compiler > Show Build Properties and Verbose
  • Re-Compile your program with these settings enabled
 
Save the new Output to a Text File and....
Support requests without the output above may be impossible to answer, so please help us to help you
 
  HomeSearch Tutorials & Wiki visualmicro.com LoginHelpRegister  
 
Page Index Toggle Pages: 1
Send Topic Print
Missing uploader option "Atmel Studio JTAG ICE3 (JTAG)" (Read 392 times)
Alexander Gräf
Newbies
*
Offline



Posts: 1
Missing uploader option "Atmel Studio JTAG ICE3 (JTAG)"
Mar 19th, 2019 at 4:22pm
 
In the uploader options, there is the option to use:

Atmel Studio JTAG ICE3 (ISP)

This is favorable as the Atmel Studio built-in programming works more reliable with e.g. the ICE3 programmer. However, when debugging is required, it is necessary to switch the connection to JTAG. However, there is no corresponding programming mode, which might look like:

Atmel Studio JTAG ICE3 (JTAG)

Using "Atmel JTAGICE3 (JTAG mode)" isn't really reliable, and while using "Atmel Studio Device Programming" does work, I need to manually start the upload in the "Device Programming" dialog every time I do a build.

Can you please add an option so that Visual Micro will use the built-in JTAG programming from Atmel Studio in the same way it already works for ISP?

Thank you.
Back to top
 
 
IP Logged
 
Visual Micro
Administrator
*****
Offline



Posts: 10623
United Kingdom
Re: Missing uploader option "Atmel Studio JTAG ICE3 (JTAG)"
Reply #1 - Mar 19th, 2019 at 4:31pm
 
The programmers in the list are the ones provided by arduino.cc and some by a few users.

The best option is to use the "Use Atmel Studio Device Programming" but I need to look into why you feel you have to manually start the upload each time you click "Start>Debug" or "Start>Without Debug".  Is this the issue?

Out of interest, have you got "Debugger>Use atmel studio debugging" enabled?

Back to top
 
WWW  
IP Logged
 
Page Index Toggle Pages: 1
Send Topic Print