Welcome, Guest. Please Login or Register
Arduino IDE for Visual Studio
 
 
When Logging a Support Issue in the Forum, please ensure you have also:-
  • Enabled vMicro > Compiler > Show Build Properties and Verbose
  • Re-Compile your program with these settings enabled
 
Save the new Output to a Text File and....
Support requests without the output above may be impossible to answer, so please help us to help you
 
  HomeSearch Tutorials & Wiki visualmicro.com LoginHelpRegister  
 
Page Index Toggle Pages: 1
Send Topic Print
AdaFruit Feather MO Lora Radio Board - The system cannot find the file specified (Read 386 times)
N Longo
Newbies
*
Offline



Posts: 3
AdaFruit Feather MO Lora Radio Board - The system cannot find the file specified
May 23rd, 2019 at 6:38pm
 
I'm liking your plug-in and was working well when working with a straight Arduino Uno board.  When I started my project on an Adafruit Feather MO Lora board I can't get the project to load onto the board.  It seems like a COMs/maybe boot loader issue.

Running the same sketch with Arduino IDE and same comm ports works just fine.  I have loaded the boards and libraries in Visual studio (successful compile and can select the desired boards).  I've seen another post about selecting a programmer.  Only two show available for this board and I have tried both (J-Link over OpenOCD and Atmel ICE over OpenOCD).  Neither makes a difference.

I've attached the build output per your forum instructions.

Thank you for your assistance.
Back to top
 

 
IP Logged
 
Visual Micro
Administrator
*****
Offline



Posts: 10631
United Kingdom
Re: AdaFruit Feather MO Lora Radio Board - The system cannot find the file specified
Reply #1 - May 23rd, 2019 at 6:42pm
 
Hi

Thanks for the report. The issue looks like we can't find the bossca tool which is why we see this variable unresolved when the upload happens {runtime.tools.bossac-1.7.0.path}

We will test and resolve over the next few days. In the meantime in the arduino ide you can enable "external editor" in file preferences and have the same sketch open in both vs and arduino at the same time. this means you can click upload in arduino.
Back to top
 
WWW  
IP Logged
 
Visual Micro
Administrator
*****
Offline



Posts: 10631
United Kingdom
Re: AdaFruit Feather MO Lora Radio Board - The system cannot find the file specified
Reply #2 - May 23rd, 2019 at 6:54pm
 
I just installed the adafruit package and tested build/upload to a feather m0 which worked okay.

I suspect that the issue is that arduino has only installed part of the tool chain because you maybe also have the arduino samd tools installed already. Visual Micro should do same.

A workaround should be to use board manager in visual micro to first click the adafruit tool chain and uninstall it then click it again and install. Then click the rescan button and upload should work okay.



ps: It's not a problem if the board is already in bootloader mode. Either port should work fine.
Back to top
 
WWW  
IP Logged
 
N Longo
Newbies
*
Offline



Posts: 3
Re: AdaFruit Feather MO Lora Radio Board - The system cannot find the file specified
Reply #3 - May 23rd, 2019 at 8:18pm
 
Thank you for the response...you were correct.  I missed loading the Arduino SAMD packages.  I had to remove everything and restart Visual Studio before adding back in.  Rescanning wasn't working.  After though I was able to load to the board.

Still have trouble now getting the Serial Monitor to connect.  Fails to open port.  I do have it switched onto the right port and the correct baud rate set.

Reguardless of Arduino or Visual Studio, I have to put the board in bootloader mode to load it and that comes across as COM6.  Once flashed and running it switches to COM7.  With Arduino IDE though I can switch over and connect the serial monitor just fine.  Visual Studio fails to open the port.

Further attempts to upload via Visual Studio fail as it appears the ports are now locked but I can't figure out what locked them.  I posted an update of where it's failing now.  I'm sure it's me, I just don't know what I've done.

The reason I believe something is connecting and not letting go is my sketch isn't supposed to start until there is a serial connection which does just that when loaded through Arduino.  When I successfully loaded through Visual Studio the sketch ran immediately.  Is there something else with Visual Micro that connects serially after load?  A debugger for instances?  Is that grabbing the port and not allowing the Serial Monitor to connect?  Something seems to be connecting serially right after loading.


I noticed the "Help" message when you hover over "Connect" that it starts a debug automatically.  That's what sparked my question above about a debugger.  I see not other indication a debugger is running.  I'm quite familiar with Visual Studio but my first using it for Arduino development.

Thoughts on this next issue?
Back to top
 
 
IP Logged
 
N Longo
Newbies
*
Offline



Posts: 3
Re: AdaFruit Feather MO Lora Radio Board - The system cannot find the file specified
Reply #4 - May 23rd, 2019 at 10:19pm
 
I may have gotten past whatever my issue was. I noticed I had a pending Visual studio update as well as a pending Visual Macro update.  I ran both, rebooted and things are pretty smooth at the moment.

Thank you.
Back to top
 
 
IP Logged
 
N Longo
Newbies
*
Offline



Posts: 3
Re: AdaFruit Feather MO Lora Radio Board - The system cannot find the file specified
Reply #5 - May 24th, 2019 at 3:24pm
 
I was a little premature saying I got past the issues.  It's flacky.  It will work but then I need to reboot the whole machine again because it seems like something retains hold on the port.  I fully disconnect the board, repower it, reset it...nothing seems to change.  Windows shows the device appearing and disappearing but still can't actually upload to the device nor connect a serial connection.  Everything looks the same as my previous uploads of the build process accept these final lines.

Quote:
Uploading 'PoolTemp' to 'Adafruit Feather M0' using 'COM6'
Unable to 'touch' hardware serial port: COM6. Now assuming selected port is bootloader port. This might still fail, have you got the correct board selected?
The uploader process failed
# Copy build result to 'Project>Property Pages>Intermediate Directory'
# Destination: file:///C:/Users/diver/source/repos/PoolTemp/Debug/

No device found on COM6
Back to top
 
 
IP Logged
 
Visual Micro
Administrator
*****
Offline



Posts: 10631
United Kingdom
Re: AdaFruit Feather MO Lora Radio Board - The system cannot find the file specified
Reply #6 - May 24th, 2019 at 3:39pm
 
is the usb cable plugged directly into the pc or via a hub?

when the upload works what is the com port number?

please also try this version which gives a slight breather after try to switch to bootloader mode and also fixes a debugger issue for the feather M0. https://www.visualmicro.com/forums/YaBB.pl?num=1558696954/0#0

Thanks
Back to top
« Last Edit: May 24th, 2019 at 4:28pm by Visual Micro »  
WWW  
IP Logged
 
Page Index Toggle Pages: 1
Send Topic Print