Welcome, Guest. Please Login or Register
Arduino IDE for Visual Studio
 
 
When Logging a Support Issue in the Forum, please ensure you have also:-
  • Enabled vMicro > Compiler > Show Build Properties and Verbose
  • Re-Compile your program with these settings enabled
 
Save the new Output to a Text File and....
Support requests without the output above may be impossible to answer, so please help us to help you
 
  HomeSearch Tutorials & Wiki visualmicro.com LoginHelpRegister  
 
Page Index Toggle Pages: 1
Send Topic Print
Output window only shows Micro Build (Read 509 times)
tfact129
Newbies
*
Offline



Posts: 4
Output window only shows Micro Build
May 30th, 2019 at 10:53pm
 
My output window is not showing Micro Debug only Micro Build. Also the preferences in the serial monitor are greyed out. I have set to Automatic Debugging. Whats wrong?
Back to top
 
 
IP Logged
 
Visual Micro
Administrator
*****
Offline



Posts: 10620
United Kingdom
Re: Output window only shows Micro Build
Reply #1 - May 30th, 2019 at 10:58pm
 
Hi

Is you tool bar set to "Debug" or "Release"?

Back to top
 
WWW  
IP Logged
 
tfact129
Newbies
*
Offline



Posts: 4
Re: Output window only shows Micro Build
Reply #2 - May 30th, 2019 at 11:09pm
 
It's set to debug
Back to top
 
 
IP Logged
 
Visual Micro
Administrator
*****
Offline



Posts: 10620
United Kingdom
Re: Output window only shows Micro Build
Reply #3 - May 30th, 2019 at 11:13pm
 
okay please follow the instruction at the top of the forum so that we get the output from a debug upload then we can see your settings.

Thanks
Back to top
 
WWW  
IP Logged
 
tfact129
Newbies
*
Offline



Posts: 4
Re: Output window only shows Micro Build
Reply #4 - May 30th, 2019 at 11:26pm
 
Please gimme a link me where to get the instruction
Back to top
 
 
IP Logged
 
Visual Micro
Administrator
*****
Offline



Posts: 10620
United Kingdom
Re: Output window only shows Micro Build
Reply #5 - May 30th, 2019 at 11:31pm
 
It's in the yellow box at the top of this page

see the text "When Logging a Support Issue in the Forum, please ensure you have also:-"
Back to top
« Last Edit: May 30th, 2019 at 11:45pm by Visual Micro »  
WWW  
IP Logged
 
tfact129
Newbies
*
Offline



Posts: 4
Re: Output window only shows Micro Build
Reply #6 - May 31st, 2019 at 3:58pm
 
Log file sent to support via mail
Back to top
 
 
IP Logged
 
Visual Micro
Administrator
*****
Offline



Posts: 10620
United Kingdom
Re: Output window only shows Micro Build
Reply #7 - May 31st, 2019 at 5:34pm
 
Thanks, config looks good. atmega2560 in debug mode. I can only assume the debug startup commands have not been injected for some reason. Maybe related to the layout of syntax around the setup() method where we inject the commands.

Please zip and email this file C:\Users\abc\AppData\Local\Temp\VMBuilds\20190530_topo_main\mega_atmega2560\Debu
g\20190530_topo_main.cpp
Back to top
 
WWW  
IP Logged
 
tfact129
Newbies
*
Offline



Posts: 4
Re: Output window only shows Micro Build
Reply #8 - May 31st, 2019 at 8:45pm
 
Mail with cpp file sent
Back to top
 
 
IP Logged
 
tfact129
Newbies
*
Offline



Posts: 4
Re: Output window only shows Micro Build
Reply #9 - May 31st, 2019 at 9:09pm
 
For whatever reason - it works now Wink
Back to top
 
 
IP Logged
 
Page Index Toggle Pages: 1
Send Topic Print