Welcome, Guest. Please Login or Register
Arduino IDE for Visual Studio
 
 
When Logging a Support Issue in the Forum, please ensure you have also:-
  • Enabled vMicro > Compiler > Show Build Properties and Verbose
  • Re-Compile your program with these settings enabled
 
Save the new Output to a Text File and....
Support requests without the output above may be impossible to answer, so please help us to help you
 
  HomeSearch Tutorials & Wiki visualmicro.com LoginHelpRegister  
 
Pages: 1 2 3 4 
Send Topic Print
Atmel ICE debugger not detected (Read 2379 times)
Visual Micro
Administrator
*****
Offline



Posts: 10463
United Kingdom
Re: Atmel ICE debugger not detected
Reply #40 - Jul 16th, 2019 at 1:40pm
 
Hi

F5 is Debug>Start and I explained in my last message that causes upload to fail. Serial upload on the Due is not possible when you connect the JTAG

Upload without JTAG connected and then plug in the ICE/JTAG and click "Debug>Attach". Do not click F5

In future release you will be able to use ICE for upload as well as for debug. Then you will be able to click F5



One last point, set the Optimization to "No project + libraries" or higher.
Back to top
 
WWW  
IP Logged
 
MARCO_ITALY
Junior Member
**
Offline



Posts: 52
Re: Atmel ICE debugger not detected
Reply #41 - Jul 16th, 2019 at 2:03pm
 
Sorry,
but is where the Attach command ? in my Menu (vMicro) there aren't

n vs2019 there is a debug menù but there is not attach

do you mean CRTL + ALT + P  ???
Shocked

Back to top
 
 
IP Logged
 
Visual Micro
Administrator
*****
Offline



Posts: 10463
United Kingdom
Re: Atmel ICE debugger not detected
Reply #42 - Jul 16th, 2019 at 2:46pm
 
Please see the Debug menu at the top of the Visual Studio IDE. It contains the real names of the short cut keys you talk.

"Debug>Attach To Process"

There will be some videos produced during the coming weeks. It might be an idea for you to wait for them because they will answer a lot of questions.

Back to top
« Last Edit: Jul 16th, 2019 at 2:46pm by Visual Micro »  
WWW  
IP Logged
 
MARCO_ITALY
Junior Member
**
Offline



Posts: 52
Re: Atmel ICE debugger not detected
Reply #43 - Jul 16th, 2019 at 3:17pm
 
Ok Find it attach to Process
Compiling: OK
Uploading: OK

disconnetting USB form Programming port

Connetting USB cable to ICE/JTAG
set debug: hardware Atmel ICE
lunch  attach to Process

there is a error:
Unable to start debugging . The satellite assembley named
"Microsoft.VisualStudio.Shell.UI.Internal.reasources.ddl,Version 16.0.0.0, Pubblic KeyToken=b03f5f7f11d5a3a For fallback culture "en" either could not be found or could not be loaded. This is generally a setaup problem. Please consider reinstalling or reparign application.

Sad


Back to top
 
 
IP Logged
 
Visual Micro
Administrator
*****
Offline



Posts: 10463
United Kingdom
Re: Atmel ICE debugger not detected
Reply #44 - Jul 16th, 2019 at 4:09pm
 
This seems to be an internal visual studio error similar to the status bar error you encountered the other day.

The error says that visual studio can't find the standard american/english  (en) language files. We might have to report the issue to Microsoft as I suspect it is a VS2019 issue.

What languages show on your task bar? I assume you have maybe Italian as default? Does USA/UK (en) show as a language? If not please enable it. I am not asking you to switch from your language just to ensure the language support files are available to your machine for USA/UK

Thanks

Back to top
 
WWW  
IP Logged
 
MARCO_ITALY
Junior Member
**
Offline



Posts: 52
Re: Atmel ICE debugger not detected
Reply #45 - Jul 16th, 2019 at 4:44pm
 
Hi!
OK I have removed the italian lang. and installed the english
language.

now there is a new error.
unable to  find the file:
directory: vmicro\tools\open-0.10.0.1\bin\openocd.exe
Shocked
Back to top
 
 
IP Logged
 
Simon Hopkinson
Administrator
*****
Offline



Posts: 43
Re: Atmel ICE debugger not detected
Reply #46 - Jul 16th, 2019 at 5:27pm
 
If you try and press Debug > Attach to Process again it should have installed the extra tools (it downloads them the first time you attach to a board requiring them)

If not, can you confirm there is a folder on your PC:
C:\ProgramData\VMicro\tools\openocd-0.10.0.1

If not please post the "Micro Build" output after the failed attach, as this should now show the tool download if it is not installed:

Downloading tool to C:\ProgramData\vmicro\tools\openocd-0.10.0.1\openocd-0.10.0.1.zip
Installing tool.
Back to top
 
 
IP Logged
 
MARCO_ITALY
Junior Member
**
Offline



Posts: 52
Re: Atmel ICE debugger not detected
Reply #47 - Jul 17th, 2019 at 6:41am
 
Hi !

Yes I have a folder
C:\ProgramData\VMicro\tools\openocd-0.10.0.1
I have to tryed again to start the debug...always fail.

In this folder is not present openocd.exe


where  can I find the file openocd-0.10.0.1.zip to downloading?

Smiley

Back to top
 
 
IP Logged
 
MARCO_ITALY
Junior Member
**
Offline



Posts: 52
Re: Atmel ICE debugger not detected
Reply #48 - Jul 17th, 2019 at 6:43am
 
This is my microbuild on debug fail connection
# MI Debugger Properties
{
  "serverLaunchTimeout": 5000,
  "filterStdout": false,
  "filterStderr": true,
  "targetArchitecture": "arm",
  "stopAtEntry": false,
  "externalConsole": false,
  "MIMode": "gdb",
  "MIDebuggerServerAddress": "localhost:3333",
  "cwd": "C:\\Users\\marco\\AppData\\Local\\Temp\\VMBuilds\\ArduinoDueProject\\arduino_du
e_x_dbg\\Debug",
  "MIDebuggerPath": "C:\\Users\\marco\\AppData\\Local\\arduino15\\packages\\arduino\\tools\\arm-none
-eabi-gcc\\4.8.3-2014q1/bin\\arm-none-eabi-gdb.exe",
  "MIDebuggerArgs": "",
  "debugServerPath": "C:\\ProgramData\\vmicro\\tools\\openocd-0.10.0.1\\bin/openocd.exe",
  "debugServerArgs": "-d2 -s \"C:\\ProgramData\\vmicro\\tools\\openocd-0.10.0.1/share/openocd/scripts/\" -c \"interface cmsis-dap\" -c \"cmsis_dap_vid_pid 0x03eb 0x2141\" -c \"set CHIPNAME at91sam3X8E\" -c \"source [find target/at91sam3XXX.cfg]\" -c \"init; reset halt\"",
  "program": "C:/Users/marco/AppData/Local/Temp/VMBuilds/ArduinoDueProject/arduino_due_x_dbg/
Debug/ArduinoDueProject.ino.elf",
  "logging": {
    "moduleLoad": false,
    "trace": false,
    "engineLogging": false,
    "programOutput": false,
    "exceptions": false,
    "traceResponse": false
  },
  "visualizerFile": "C:\\Users\\marco\\AppData\\Local\\Temp\\VMBuilds\\ArduinoDueProject\\arduino_du
e_x_dbg\\Debug\\debugger_tmp.natvis",
  "showDisplayString": true
}
Back to top
 
 
IP Logged
 
Simon Hopkinson
Administrator
*****
Offline



Posts: 43
Re: Atmel ICE debugger not detected
Reply #49 - Jul 17th, 2019 at 9:57am
 
The ZIP can be downloaded from the link below manually:
https://www.visualmicro.com/downloads/tools/openocd-0.10.0.1/openocd-0.10.0.1.zi...

This needs extracting to "C:\Program Data\vMicro\tools\", and after this you should be able to see files in the folder, for example in the "C:\Program Data\vMicro\tools\openocd-0.10.0.1\bin" folder should be "openocd.exe" and a number of dll files.

The debugger should start once these files are in place.

If it fails after this, please re-attach the whole Micro Build log from the next run.
Back to top
 
 
IP Logged
 
MARCO_ITALY
Junior Member
**
Offline



Posts: 52
Re: Atmel ICE debugger not detected
Reply #50 - Jul 17th, 2019 at 10:23am
 
WOW!
WOW!
WOW!
Cheesy Grin
Cheesy Grin
Back to top
 
 
IP Logged
 
MARCO_ITALY
Junior Member
**
Offline



Posts: 52
Re: Atmel ICE debugger not detected
Reply #51 - Jul 17th, 2019 at 10:27am
 
Thanks! Now it  W O R K ! with Atmle ICE

Now I'm Waiting for final version with the possibility to unify compiling + downloading  + debug using only a ICE debug.

Next Week?
Back to top
 
 
IP Logged
 
MARCO_ITALY
Junior Member
**
Offline



Posts: 52
Re: Atmel ICE debugger not detected
Reply #52 - Jul 19th, 2019 at 6:13pm
 
Hi!
When do you think will to be ready a new version for  uploading + debuging using only ICE Atmel?

ciao
Marco
Back to top
 
 
IP Logged
 
MARCO_ITALY
Junior Member
**
Offline



Posts: 52
Re: Atmel ICE debugger not detected
Reply #53 - Jul 23rd, 2019 at 7:19am
 
Hi! some news about this treat?
Smiley
Back to top
 
 
IP Logged
 
Visual Micro
Administrator
*****
Offline



Posts: 10463
United Kingdom
Re: Atmel ICE debugger not detected
Reply #54 - Jul 23rd, 2019 at 10:10am
 
There will be a release over the next couple of weeks with a full range of programmer/uploader support. It involves a lot of different boards so will take a little time.

Please watch out for release notifications in the releases section.
Back to top
 
WWW  
IP Logged
 
MARCO_ITALY
Junior Member
**
Offline



Posts: 52
Re: Atmel ICE debugger not detected
Reply #55 - Jul 23rd, 2019 at 12:35pm
 
Ok thanks!
Good job!
Cheesy
Back to top
 
 
IP Logged
 
MARCO_ITALY
Junior Member
**
Offline



Posts: 52
Re: Atmel ICE debugger not detected
Reply #56 - Aug 5th, 2019 at 3:42pm
 
Hi, I see the new versione 1908.04  is this the right version to solve my problem?
upload + debugging using Atmel ICE emulator
ciao
Marco
Back to top
 
 
IP Logged
 
Visual Micro
Administrator
*****
Offline



Posts: 10463
United Kingdom
Re: Atmel ICE debugger not detected
Reply #57 - Aug 5th, 2019 at 3:47pm
 
If you see a flag at the top of the IDE that means there is a full new release from the Gallery. Today we published 1908.5 to the Gallery.

The release should provide hardware debugging with the ICE but it is not an emulator it is "real time". We do not provie an emulator but maybe you used the wrong word by mistake Smiley
Back to top
« Last Edit: Aug 5th, 2019 at 3:48pm by Visual Micro »  
WWW  
IP Logged
 
MARCO_ITALY
Junior Member
**
Offline



Posts: 52
Re: Atmel ICE debugger not detected
Reply #58 - Aug 5th, 2019 at 3:55pm
 
Hi yes of course, is a wrong word -emulator-. I want use your debug step by step using the Atmel ICE, including the uploading of the code via Atmel IC also
ciao
Marco
Back to top
 
 
IP Logged
 
Simon Hopkinson
Administrator
*****
Offline



Posts: 43
Re: Atmel ICE debugger not detected
Reply #59 - Aug 5th, 2019 at 4:05pm
 
If you download and install the latest release this should now work for you as expected with the ICE Debugging and Upload, with the Due
Back to top
 
 
IP Logged
 
Pages: 1 2 3 4 
Send Topic Print