Welcome, Guest. Please Login or Register
Arduino IDE for Visual Studio
 
 
When Logging a Support Issue in the Forum, please ensure you have also:-
  • Enabled vMicro > Compiler > Show Build Properties and Verbose
  • Re-Compile your program with these settings enabled
 
Save the new Output to a Text File and....
Support requests without the output above may be impossible to answer, so please help us to help you
 
  HomeSearch Tutorials & Wiki visualmicro.com LoginHelpRegister  
 
Page Index Toggle Pages: 1
Send Topic Print
SetSite failed error, installing with VS Community 2017 (Read 207 times)
John2006_ty
Newbies
*
Offline



Posts: 9
SetSite failed error, installing with VS Community 2017
Aug 7th, 2019 at 6:20am
 
Trying to install vmicro <Visual.Micro.Arduino.Studio_1908_5_0> with VS 2017 Community. After installation I have got SetSite installed error in ActivityLog:

Code (HTML):
  <entry>
    <record>1400</record>
    <time>2019/08/07 05:17:07.024</time>
    <type>Error</type>
    <source>VisualStudio</source>
    <description>SetSite failed for package [Visual_Micro_StudioPackage]Source: &apos;Visual.Micro.Arduino.Studio&apos; Description: Could not load file or assembly &apos;Microsoft.VisualStudio.Threading, Version=15.8.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a&apos; or one of its dependencies. The system cannot find the file specified.&#x000D;&#x000A;System.IO.FileNotFoundException: Could not load file or assembly &apos;Microsoft.VisualStudio.Threading, Version=15.8.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a&apos; or one of its dependencies. The system cannot find the file specified.&#x000D;&#x000A;File name: &apos;Microsoft.VisualStudio.Threading, Version=15.8.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a&apos;&#x000D;&#x000A;   at Visual.Micro.Studio.Visual_Micro_StudioPackage.InitializeAsync(CancellationToken cancellationToken, IProgress`1 progress)&#x000D;&#x000A;   at Microsoft.VisualStudio.Shell.AsyncPackage.&lt;&gt;c__DisplayClass17_0.&lt;&lt;Microsoft-VisualStudio-Shell-Interop-IAsyncLoadablePackageInitialize-Initialize&gt;b__1&gt;d.MoveNext()&#x000D;&#x000A;--- End of stack trace from previous location where exception was thrown ---&#x000D;&#x000A;   at Microsoft.VisualStudio.Services.VsTask.RethrowException(AggregateException e)&#x000D;&#x000A;   at Microsoft.VisualStudio.Services.VsTask.InternalGetResult(Boolean ignoreUIThreadCheck)&#x000D;&#x000A;   at Microsoft.VisualStudio.Services.VsTask.GetResult()&#x000D;&#x000A;&#x000D;&#x000A;WRN: Assembly binding logging is turned OFF.&#x000D;&#x000A;To enable assembly bind failure logging, set the registry value [HKLM\Software\Microsoft\Fusion!EnableLog] (DWORD) to 1.&#x000D;&#x000A;Note: There is some performance penalty associated with assembly bind failure logging.&#x000D;&#x000A;To turn this feature off, remove the registry value [HKLM\Software\Microsoft\Fusion!EnableLog].&#x000D;&#x000A;</description>
    <guid>{C2B94433-1774-4242-8062-987A4484F1ED}</guid>
    <hr>80070002</hr>
    <errorinfo></errorinfo>
  </entry>
  <entry>
    <record>1401</record>
    <time>2019/08/07 05:17:07.037</time>
    <type>Error</type>
    <source>VisualStudio</source>
    <description>End package load [Visual_Micro_StudioPackage]</description>
    <guid>{C2B94433-1774-4242-8062-987A4484F1ED}</guid>
    <hr>80070002</hr>
    <errorinfo></errorinfo>
  </entry> 



My .Net Framework version is 4.7.02558.

Now all menus from vMicro top menu bar is not responsive. That means vMicro is not installed correctly.

How to solve this problem?

Back to top
 
 
IP Logged
 
Visual Micro
Administrator
*****
Offline



Posts: 10395
United Kingdom
Re: SetSite failed error, installing with VS Community 2017
Reply #1 - Aug 7th, 2019 at 12:06pm
 
Microsoft have made a lot of changes for Vs2019 and have made them backware compatible to Vs2017 via the standard visual studio update system. I asked Microsoft which versions of their dlls work with which version of Vs2017 and they said they were not entirely sure at the moment.

I think the moral of the story is to make sure VS is up to date Smiley

I suspect your vs has not been updated for some time. Please use the Help menu to apply the Vs2017 update.

Does this solve the issue?
Back to top
 
WWW  
IP Logged
 
Visual Micro
Administrator
*****
Offline



Posts: 10395
United Kingdom
Re: SetSite failed error, installing with VS Community 2017
Reply #2 - Aug 7th, 2019 at 12:06pm
 
Microsoft have made a lot of changes for Vs2019 and have made them backware compatible to Vs2017 via the standard visual studio update system. We asked Microsoft which versions of their dlls work with which version of Vs2017 and they said they were not entirely sure at the moment.

Back in April we also became compatible with Vs2019. I think the moral of the story is to make sure VS is up to date Smiley

I suspect your vs has not been updated for some time. Please use the Help menu to apply the Vs2017 update.

Does this solve the issue?
Back to top
« Last Edit: Aug 7th, 2019 at 12:08pm by Visual Micro »  
WWW  
IP Logged
 
John2006_ty
Newbies
*
Offline



Posts: 9
Re: SetSite failed error, installing with VS Community 2017
Reply #3 - Aug 7th, 2019 at 12:46pm
 
Tim

I have installed a fresh copy VS2019 right away. It works.

Thanks a lot.

John Smiley
Back to top
 
 
IP Logged
 
Visual Micro
Administrator
*****
Offline



Posts: 10395
United Kingdom
Re: SetSite failed error, installing with VS Community 2017
Reply #4 - Aug 7th, 2019 at 2:27pm
 
Great, in vs2019 please see the news above about switch off "optimize rendering for different screen densities..." otherwise the serial and explore tool windows will probably be transprent without content.

We are working on switching the tool windows from windows forms to wpf which comply with the new vs scaling system.
Back to top
 
WWW  
IP Logged
 
John2006_ty
Newbies
*
Offline



Posts: 9
Re: SetSite failed error, installing with VS Community 2017
Reply #5 - Aug 7th, 2019 at 4:58pm
 
From where <"optimize rendering for different screen densities..."> can be switched off? I tried [Tools] > [Options] > [Environment] > [General] dialog but cannot find it.
Back to top
 
 
IP Logged
 
Visual Micro
Administrator
*****
Offline



Posts: 10395
United Kingdom
Re: SetSite failed error, installing with VS Community 2017
Reply #6 - Aug 7th, 2019 at 5:02pm
 
If you are using VS2017 then ignore my post about the pixel densities.
Back to top
 
WWW  
IP Logged
 
John2006_ty
Newbies
*
Offline



Posts: 9
Re: SetSite failed error, installing with VS Community 2017
Reply #7 - Aug 7th, 2019 at 5:04pm
 
Now I see it. Because I am using Win 7 so, there is no "Optimize rendering option" for me. It has been disabled by default.
Back to top
 
 
IP Logged
 
Visual Micro
Administrator
*****
Offline



Posts: 10395
United Kingdom
Re: SetSite failed error, installing with VS Community 2017
Reply #8 - Aug 7th, 2019 at 5:06pm
 
Oh, that's interesting. Now I see too thanks Smiley
Back to top
 
WWW  
IP Logged
 
Page Index Toggle Pages: 1
Send Topic Print