Welcome, Guest. Please Login or Register
Arduino IDE for Visual Studio
 
 
When Logging a Support Issue in the Forum, please ensure you have also:-
  • Enabled vMicro > Compiler > Show Build Properties and Verbose
  • Re-Compile your program with these settings enabled
 
Save the new Output to a Text File and....
Support requests without the output above may be impossible to answer, so please help us to help you
 
  HomeSearch Tutorials & Wiki visualmicro.com LoginHelpRegister  
 
Page Index Toggle Pages: 1
Send Topic Print
New vMicro project created from vMicro DO NOT compile - no Output (Read 438 times)
peryss
Junior Member
**
Offline



Posts: 32
New vMicro project created from vMicro DO NOT compile - no Output
Aug 30th, 2019 at 9:57am
 
Hello,
I trying to create first "Arduino" project from vMicro at AVRS7.

When I create new project and type at INO file first Arduino functions, as "digitalWrite()" it recognizes built-in libraries, I am getting suggestions, but- I can not compile project.
It simply Do NOT start compilling, AVRS's Output window only goes into focus (yellow frame) but stys clean.

vMicro shows correctly project directory ets, but does not compile.

What could be wrong?
Thank you, Jiri
Back to top
 
 
IP Logged
 
Visual Micro
Administrator
*****
Offline



Posts: 10623
United Kingdom
Re: New vMicro project created from vMicro DO NOT compile - no Output
Reply #1 - Aug 30th, 2019 at 11:53am
 
When did you install atmel studio?
Back to top
 
WWW  
IP Logged
 
peryss
Junior Member
**
Offline



Posts: 32
Re: New vMicro project created from vMicro DO NOT compile - no Output
Reply #2 - Aug 30th, 2019 at 12:21pm
 
Hi,
before let say 2 years... but I have made update to latest release, just before proceding to innstall vMicro (from AVRS Tools/Extension menu.

There are few points...
- when I made first test, I have created test project from ArduinoIDE, then reopened it via vMicro and it runs. Next day, after my PC powering, it do not do compilation as I wrote above.
- the same is now when I created new project from vMicro directly as i wrote above
- BUT - it seems when AVRS is opened, and then do start ArduinoIDE, make a compilation from it, then next start AVRS fills its Output window with few "Object" errors - and then compilation from vMicro runs fine.

When I tried to create vMicro project from Start-page of AVRS, it does not give me any suggestions when typing source code, nevertheless it can be compilled but with notices that vMicro uses libraries from previous session... so I do not testet this way any more and return myself to create project from vMicro menu.

Jiri
Back to top
 
 
IP Logged
 
peryss
Junior Member
**
Offline



Posts: 32
Re: New vMicro project created from vMicro DO NOT compile - no Output
Reply #3 - Aug 30th, 2019 at 12:31pm
 
I make few snapshots of (no)compiling process.
..please note the AVRS was not reinstalled fully but only updated - before vmicro Extension install.
..second note, even if theese errors at start of AVRS are seen, it compiles INO file fine, uploads it to Arrduino hw and runs ok.
Jiri
Back to top
 
 
IP Logged
 
peryss
Junior Member
**
Offline



Posts: 32
Re: New vMicro project created from vMicro DO NOT compile - no Output
Reply #4 - Aug 30th, 2019 at 12:32pm
 
next ones.
Back to top
 
 
IP Logged
 
Visual Micro
Administrator
*****
Offline



Posts: 10623
United Kingdom
Re: New vMicro project created from vMicro DO NOT compile - no Output
Reply #5 - Aug 30th, 2019 at 2:55pm
 
You should close the IO window so we can see your solution in the solution explorer.

I would also ignore the start window because it also causes confusion.

Please use "File>New>Project>Arduino Project" to create a project using the atmel studio new project wizard. Then confirm if that works or not.

Thanks
Back to top
« Last Edit: Aug 30th, 2019 at 2:55pm by Visual Micro »  
WWW  
IP Logged
 
peryss
Junior Member
**
Offline



Posts: 32
Re: New vMicro project created from vMicro DO NOT compile - no Output
Reply #6 - Aug 30th, 2019 at 6:43pm
 
unfortunately, this time I was not able to do this.
first time this action (File-New-Project-ArduinoSkatch) hangs-up AVRS with OutputWindow empty..
After restart AVRS come up with OutputWindow with errors, but after dialog "Visual Micro - Undo the changes Atmel 7.0 has made?.." I confirm YES and AVRS has restarted again.
Third attempt it hang u again...

Yestarday I had performed this action (I wrote it above), this did not give me sugestions and it seems that AVRS/vMicro did not recognise any libraries..

Back to top
 
 
IP Logged
 
Visual Micro
Administrator
*****
Offline



Posts: 10623
United Kingdom
Re: New vMicro project created from vMicro DO NOT compile - no Output
Reply #7 - Aug 30th, 2019 at 7:00pm
 
try a repair on atmel studio
Back to top
 
WWW  
IP Logged
 
peryss
Junior Member
**
Offline



Posts: 32
Re: New vMicro project created from vMicro DO NOT compile - no Output
Reply #8 - Aug 30th, 2019 at 7:12pm
 
meantime, I made notebook reboot...

now, AVRS started with OutputWindow with errors, and I was able to create new Sketch as you asked - now when I typing "digitalWrite() it gives a sugestions (ok) and allow me to Goto Implementation, but when I add user library it did not allow me to Goto Implementation.

I then reopened my last attempt when project was created from vMicro menu, and it works fine including to Add user library and Goto Implementation..

I try to make shots where Project window could be seen.
Back to top
 
 
IP Logged
 
Visual Micro
Administrator
*****
Offline



Posts: 10623
United Kingdom
Re: New vMicro project created from vMicro DO NOT compile - no Output
Reply #9 - Aug 30th, 2019 at 7:15pm
 
does build work?
Back to top
 
WWW  
IP Logged
 
peryss
Junior Member
**
Offline



Posts: 32
Re: New vMicro project created from vMicro DO NOT compile - no Output
Reply #10 - Aug 30th, 2019 at 7:16pm
 
..but it allows to see implementation embeded Arduino libs as digitalWrite()...
last shot shows project created from vMicro, here it allows to see implementaton the same user library withput any problem..

(sure both cases if AVRS has started with OutputWindow filled with errors, not clean Smiley
Back to top
 
 
IP Logged
 
peryss
Junior Member
**
Offline



Posts: 32
Re: New vMicro project created from vMicro DO NOT compile - no Output
Reply #11 - Aug 30th, 2019 at 7:18pm
 
anyhow - thank you for today for your interest.
Jiri
Back to top
 
 
IP Logged
 
Visual Micro
Administrator
*****
Offline



Posts: 10623
United Kingdom
Re: New vMicro project created from vMicro DO NOT compile - no Output
Reply #12 - Aug 30th, 2019 at 7:18pm
 
It looks like atmel studio is not installed correctly. I suggest you install again and make sure you install support for all atmel options.
Back to top
 
WWW  
IP Logged
 
peryss
Junior Member
**
Offline



Posts: 32
Re: New vMicro project created from vMicro DO NOT compile - no Output
Reply #13 - Aug 30th, 2019 at 7:19pm
 
oh... tomorrow I wil try....
Jiri
Back to top
 
 
IP Logged
 
Page Index Toggle Pages: 1
Send Topic Print