Welcome, Guest. Please Login or Register
Arduino IDE for Visual Studio
 
 
When Logging a Support Issue in the Forum, please ensure you have also:-
  • Enabled vMicro > Compiler > Show Build Properties and Verbose
  • Re-Compile your program with these settings enabled
 
Save the new Output to a Text File and....
Support requests without the output above may be impossible to answer, so please help us to help you
 
  HomeSearch Tutorials & Wiki visualmicro.com LoginHelpRegister  
 
Page Index Toggle Pages: 1
Send Topic Print
Upload Fails, can't find file (Read 109 times)
Dave Leddon
Junior Member
**
Offline



Posts: 17
Danville, CA
Upload Fails, can't find file
Nov 8th, 2019 at 2:37am
 
Somehow I managed to get two Visual Micro add-ins in my copy of Visual Studio 2013 which screwed up the Arduino IDE path names.  Using the system Control Panel I uninstalled the second add-in and now I can build and link.

But during the upload phase I get the following error:

The system cannot find the file specified

I would guess that either path name is still wrong or the missing file was never created.
Back to top
 
 
IP Logged
 
Visual Micro
Administrator
*****
Offline



Posts: 10568
United Kingdom
Re: Upload Fails, can't find file
Reply #1 - Nov 8th, 2019 at 11:27am
 
Your output contains only half of the requested info. We can see that the tool chain can't be resolved {runtime.tools.bossac.path}

I suggest using board manager in the arduino ide to reinstall the Due/SAM tools. Uninstall then reinstall then restart vs.
Back to top
« Last Edit: Nov 8th, 2019 at 11:34am by Visual Micro »  
WWW  
IP Logged
 
Dave Leddon
Junior Member
**
Offline



Posts: 17
Danville, CA
Re: Upload Fails, can't find file
Reply #2 - Nov 8th, 2019 at 4:25pm
 
I reinstalled the Due/SAM tools and now get a different error:
bossac.exe: extra arguments found

I can load the Blink demo to this same board directly from the Arduino IDE.
Back to top
 

 
IP Logged
 
Visual Micro
Administrator
*****
Offline



Posts: 10568
United Kingdom
Re: Upload Fails, can't find file
Reply #3 - Nov 8th, 2019 at 7:30pm
 
Please make sure you switch on the other setting described above (show build properties) then post the output again.
Back to top
 
WWW  
IP Logged
 
Dave Leddon
Junior Member
**
Offline



Posts: 17
Danville, CA
Re: Upload Fails, can't find file
Reply #4 - Nov 9th, 2019 at 5:26am
 
I've looked but I can't locate "Show Build Properties" in Visual Micro.  This is an older version so perhaps it's called something else.
Back to top
 
 
IP Logged
 
Visual Micro
Administrator
*****
Offline



Posts: 10568
United Kingdom
Re: Upload Fails, can't find file
Reply #5 - Nov 9th, 2019 at 2:22pm
 
I now see that you are using visual micro in vs2013 alongside arduino 1.6 but you have installed the latest sam toolchain via board manager. It's not easy for us to support changes in toolchains for older versions of visual micro.

I can see in your latest report that the variable {upload.verify} is a new variable since the version for 2013 was release.

If your version of visual micro (you can see this in tools>extensions and updates) supports a local board.txt then you can add a workaround yourself.

On the Visual Micro "Add Code" menu there is an option to add a text file called board.txt to the project. You can also add one manually.

Put this one line in it and click save. Then try the upload again.

Code:
upload.verify= 



Back to top
 
WWW  
IP Logged
 
Page Index Toggle Pages: 1
Send Topic Print