Welcome, Guest. Please Login or Register
Arduino IDE for Visual Studio
 
 
When Logging a Support Issue in the Forum, please ensure you have also:-
  • Enabled vMicro > Compiler > Show Build Properties and Verbose
  • Re-Compile your program with these settings enabled
 
Save the new Output to a Text File and....
Support requests without the output above may be impossible to answer, so please help us to help you
 
  HomeSearch Tutorials & Wiki visualmicro.com LoginHelpRegister  
 
Page Index Toggle Pages: 1
Send Topic Print
Visual Micro VS2017 Error Message Debug Attach To Process (Read 351 times)
iKjetil
Newbies
*
Offline



Posts: 4
Visual Micro VS2017 Error Message Debug Attach To Process
Dec 19th, 2019 at 12:12pm
 
The error message I get is:
---------------------------
Microsoft Visual Studio
---------------------------
Unable to start debugging. GDB exited unexpectedly with exit code 1 (0x1).

I have read on this forum that there was supposed to be a simpler gdb config scheme coming that would make these errors go away.

Any help solving this problem? Thanks.

iKjetil
Back to top
 
 
IP Logged
 
Visual Micro
Administrator
*****
Offline



Posts: 10555
United Kingdom
Re: Visual Micro VS2017 Error Message Debug Attach To Process
Reply #1 - Dec 19th, 2019 at 1:11pm
 
Please follow the guide in the yellow box above
Back to top
 

WWW  
IP Logged
 
Simon Hopkinson
Administrator
*****
Offline



Posts: 179
Re: Visual Micro VS2017 Error Message Debug Attach To Process
Reply #2 - Dec 19th, 2019 at 1:26pm
 
Would you be able to send a screenshot of the error + IDE, and the logs from the Output Window > Micro Build and Debug ?

Just so we know what debugger / board configuration you are using, and the window output will contain further detail.  Most often this is a wiring or driver issue, but it depends on the debugger as to what drivers may be needed.
Back to top
 
 
IP Logged
 
iKjetil
Newbies
*
Offline



Posts: 4
Re: Visual Micro VS2017 Error Message Debug Attach To Process
Reply #3 - Dec 19th, 2019 at 1:36pm
 
I have followed the yellow box, so the information should be available soon.

iKjetil
Back to top
 
 
IP Logged
 
Simon Hopkinson
Administrator
*****
Offline



Posts: 179
Re: Visual Micro VS2017 Error Message Debug Attach To Process
Reply #4 - Dec 19th, 2019 at 2:23pm
 
Thanks for the build information, and we can see it is a DUE Programming port with Atmel ICE Probe

When you attach the debugger you should see something like the below in the Output Window (select Debug from the list at the top of the output window):

Code:
Starting: "C:\ProgramData\vmicro\tools\openocd-0.10.0.1\bin/openocd.exe" -d2 -l "{C:\Users\Simon\AppData\Local\Temp\VMBuilds\SAM-DUE_ATMELICE_BLINK_GDB\arduino_due_x_dbg\Debug/SAM-DUE_ATMELICE_BLINK_GDB.ino_DebugOpenOCD.log}" -s "C:\ProgramData\vmicro\tools\openocd-0.10.0.1/share/openocd/scripts/" -c "interface cmsis-dap" -c "cmsis_dap_vid_pid 0x03eb 0x2141" -c "set CHIPNAME at91sam3X8E" -c "source [find target/at91sam3ax_8x.cfg]" -c "init; reset halt"
Starting: "C:\Users\Simon\AppData\Local\arduino15\packages\arduino\tools\arm-none-eabi-gcc\4.8.3-2014q1/bin\arm-none-eabi-gdb.exe" --interpreter=mi 



One of the first parameters is the OpenOCD Log which will show if the debugger has been found (from above):
Code:
C:\Users\Simon\AppData\Local\Temp\VMBuilds\SAM-DUE_ATMELICE_BLINK_GDB\arduino_due_x_dbg\Debug/SAM-DUE_ATMELICE_BLINK_GDB.ino_DebugOpenOCD.log 



Would you be able to send this log file, and the Debug Output over after trying to attach the debugger as well?
Back to top
 
 
IP Logged
 
iKjetil
Newbies
*
Offline



Posts: 4
Re: Visual Micro VS2017 Error Message Debug Attach To Process
Reply #5 - Dec 19th, 2019 at 2:32pm
 
Se attached files for requested debug output window and ocd log. Smiley

iKjetil
Back to top
 

ocd_log.txt (0 KB | )
 
IP Logged
 
Simon Hopkinson
Administrator
*****
Offline



Posts: 179
Re: Visual Micro VS2017 Error Message Debug Attach To Process
Reply #6 - Dec 19th, 2019 at 2:54pm
 
The output in the log shows it can successfully see the ICE Debugger, but cant connect to the board. 

Can you confirm your wiring is as below (SAM port on ICE, and orientation of ribbon cable is important)

...
Back to top
 
 
IP Logged
 
iKjetil
Newbies
*
Offline



Posts: 4
Re: Visual Micro VS2017 Error Message Debug Attach To Process
Reply #7 - Dec 19th, 2019 at 3:12pm
 
My God! Was it that easy!

I had the cable from SAM port the wrong way but it gave me a green light. So I believed it was correct.

Thank you so much! Cheesy Cheesy

Best

iKjetil
Back to top
 
 
IP Logged
 
Simon Hopkinson
Administrator
*****
Offline



Posts: 179
Re: Visual Micro VS2017 Error Message Debug Attach To Process
Reply #8 - Dec 19th, 2019 at 3:17pm
 
I have done that myself many times, so know the frustration.

Glad its all working now and hope the debugging helps now its running  Smiley

Updated SAM Debugging Doc: https://www.visualmicro.com/page/SAM-Debugging.aspx
Back to top
« Last Edit: Dec 19th, 2019 at 3:31pm by Simon Hopkinson »  
 
IP Logged
 
Page Index Toggle Pages: 1
Send Topic Print