Welcome, Guest. Please Login or Register
Arduino IDE for Visual Studio
 
 
When Logging a Support Issue in the Forum, please ensure you have also:-
  • Enabled vMicro > Compiler > Show Build Properties and Verbose
  • Re-Compile your program with these settings enabled
 
Save the new Output to a Text File and....
Support requests without the output above may be impossible to answer, so please help us to help you
 
  HomeSearch Tutorials & Wiki visualmicro.com LoginHelpRegister  
 
Page Index Toggle Pages: 1
Send Topic Print
Issue turning off the debugger (Read 167 times)
Danils1
Newbies
*
Offline



Posts: 2
Issue turning off the debugger
Feb 29th, 2020 at 9:36am
 
Hello everyone,,
I just loaded it today and worked thought the video and it works great.  However when I change the mode back to release the breakpoints still show their trace message.  I even set the (micro debug) property of the project back to None.

I do still have the breakpoints in the program.

Maybe I misunderstood the video, but I thought the release or debug options would turn it on or off when you compile and re-upload the code.
Back to top
« Last Edit: Feb 29th, 2020 at 10:59pm by Danils1 »  
 
IP Logged
 
Visual Micro
Administrator
*****
Offline



Posts: 10645
United Kingdom
Re: Issue turning off the debugger
Reply #1 - Feb 29th, 2020 at 1:59pm
 
Yes it sounds like a minor bug we will fix.

Can you confirm that when you click vMicro>Debugger>Debug=Off that resolves the issue? If the option is already "Off" then re-select "Off"

Does this solve?

if not then make sure you have not enabled "Micro Debug=Full" in the F4 project properties.

note: Both of the above settings relate to the currently selected configuration name which in your case is either Release or Debug.
Back to top
« Last Edit: Feb 29th, 2020 at 2:20pm by Visual Micro »  
WWW  
IP Logged
 
Page Index Toggle Pages: 1
Send Topic Print