Welcome, Guest. Please Login or Register
Arduino IDE for Visual Studio
 
 
When Logging a Support Issue in the Forum, please ensure you have also:-
  • Enabled vMicro > Compiler > Show Build Properties and Verbose
  • Re-Compile your program with these settings enabled
 
Save the new Output to a Text File and....
  • Click the Reply button and attach as .txt file OR
  • Click here to Email us with the file attached, and a link to your post
Support requests without the output above may be impossible to answer, so please help us to help you
 
  HomeSearch Tutorials & Wiki visualmicro.com LoginHelpRegister  
 
Page Index Toggle Pages: 1
Send Topic Print
Projects with debug option not working anymore. (Read 334 times)
JVM
Newbies
*
Offline



Posts: 2
Projects with debug option not working anymore.
May 9th, 2020 at 11:32pm
 
projects with debug option not working anymore.

Release mode works fine. Nothing fancing. Arduino Nano thru USB.
could you help me?
Back to top
« Last Edit: May 10th, 2020 at 1:40pm by Visual Micro »  

Please Register or Login to the Forum to see File Attachments
 
IP Logged
 
Visual Micro
Administrator
*****
Offline



Posts: 10895
United Kingdom
Re: Projects with debug option not working anymore.
Reply #1 - May 10th, 2020 at 1:41pm
 
Please follow the guide in yellow above so that we can see your configuration.

The error can be caused by invalid breakpoint syntax but also other things, therefore we need that config info.

Thanks.
Back to top
 

Tim Leek
home
WWW  
IP Logged
 
JVM
Newbies
*
Offline



Posts: 2
Re: Projects with debug option not working anymore.
Reply #2 - May 10th, 2020 at 2:37pm
 
Here follows the log. I have gone thru the forum but no solution sims to work. Thank you.
Back to top
 

Please Register or Login to the Forum to see File Attachments
 
IP Logged
 
Visual Micro
Administrator
*****
Offline



Posts: 10895
United Kingdom
Re: Projects with debug option not working anymore.
Reply #3 - May 10th, 2020 at 5:48pm
 
Please email or zip and attach this file

Code:
C:\Users\Valeriano\AppData\Local\Temp\VMBuilds\Blink\nano_atmega328\Debug\Blink.cpp 



Thanks
Back to top
« Last Edit: May 10th, 2020 at 5:49pm by Visual Micro »  

Tim Leek
home
WWW  
IP Logged
 
Visual Micro
Administrator
*****
Offline



Posts: 10895
United Kingdom
Re: Projects with debug option not working anymore.
Reply #4 - May 23rd, 2020 at 6:58pm
 
This issue is resolved in 20.05.18.5 available here https://www.visualmicro.com/forums/YaBB.pl?board=VS_ARDUINO_EXT_RELEASES

The issue happened in recent releases if "deep search for libraries" was switched off.

Thanks for the report.
Back to top
 

Tim Leek
home
WWW  
IP Logged
 
Page Index Toggle Pages: 1
Send Topic Print