Welcome, Guest. Please Login or Register
Arduino IDE for Visual Studio
 
 
When Logging a Support Issue in the Forum, please ensure you have also:-
  • Enabled vMicro > Compiler > Show Build Properties and Verbose
  • Re-Compile your program with these settings enabled
 
Save the new Output to a Text File and....
Support requests without the output above may be impossible to answer, so please help us to help you
 
  HomeSearch Tutorials & Wiki visualmicro.com LoginHelpRegister  
 
Page Index Toggle Pages: 1
Send Topic Print
does not name type (Read 155 times)
JamesFarmer
Junior Member
**
Offline



Posts: 28
does not name type
May 18th, 2020 at 9:36pm
 
Getting erro in VM not getting the error when compiling under arduino

error: 'MQTTClient' does not name a type
   MQTTClient tclient = MQTTClient(5000)
Back to top
 
 
IP Logged
 
Visual Micro
Administrator
*****
Offline



Posts: 10653
United Kingdom
Re: does not name type
Reply #1 - May 18th, 2020 at 9:44pm
 
Please follow the guide in yellow above.
Back to top
 
WWW  
IP Logged
 
JamesFarmer
Junior Member
**
Offline



Posts: 28
Re: does not name type
Reply #2 - May 18th, 2020 at 9:56pm
 
verbos attched
Back to top
 

err.txt (1374 KB | 1 )
 
IP Logged
 
JamesFarmer
Junior Member
**
Offline



Posts: 28
Re: does not name type
Reply #3 - May 18th, 2020 at 10:18pm
 
I added it as shared reference project now works.

The issue for me is this has been working without doing this for months now out of know where I now need to add this.
Back to top
 
 
IP Logged
 
Visual Micro
Administrator
*****
Offline



Posts: 10653
United Kingdom
Re: does not name type
Reply #4 - May 18th, 2020 at 10:44pm
 
Thanks, we always need the output. It shows which board, toolchain version and what libraries have been found.

If same works in shared library it points to the possibility that the #include for a library was missing but has been added in the shared version. There should be no difference between shared code and project code.

If you can zip and email your code that fails we can look at it just so we all know what the problem was.

Thanks
Back to top
« Last Edit: May 18th, 2020 at 10:47pm by Visual Micro »  
WWW  
IP Logged
 
JamesFarmer
Junior Member
**
Offline



Posts: 28
Re: does not name type
Reply #5 - May 19th, 2020 at 1:13pm
 
The Include was not changed and the same program compiled the day before.

it also compiled fin directly in the Arduino IDE.

all I did was add it as shared project

sorry but do to parts of the code under patent review I can not share
Back to top
 
 
IP Logged
 
Visual Micro
Administrator
*****
Offline



Posts: 10653
United Kingdom
Re: does not name type
Reply #6 - May 21st, 2020 at 12:23am
 
Are you using exactly the same project to compile in the arduino ide. You haven't updated visual micro since before it has stopped working so the issue has to be an included code file in the visual studio solution that arduino does not see.
Back to top
 
WWW  
IP Logged
 
Visual Micro
Administrator
*****
Offline



Posts: 10653
United Kingdom
Re: does not name type
Reply #7 - May 21st, 2020 at 12:24am
 
Are you using exactly the same project to compile in the arduino ide. You haven't updated visual micro since before it has stopped working so the issue has to be an included code file in the visual studio solution that arduino does not see.
Back to top
 
WWW  
IP Logged
 
Page Index Toggle Pages: 1
Send Topic Print