Welcome, Guest. Please Login or Register
Arduino IDE for Visual Studio
 
 
When Logging a Support Issue in the Forum, please ensure you have also:-
  • Enabled vMicro > Compiler > Show Build Properties and Verbose
  • Re-Compile your program with these settings enabled
 
Save the new Output to a Text File and....
  • Click the Reply button and attach as .txt file OR
  • Click here to Email us with the file attached, and a link to your post
Support requests without the output above may be impossible to answer, so please help us to help you
 
  HomeSearch Tutorials & Wiki visualmicro.com LoginHelpRegister  
 
Page Index Toggle Pages: 1
Send Topic Print
VM toolbars disappered. (Read 151 times)
Kabron
Member
***
Offline



Posts: 133
VM toolbars disappered.
Sep 25th, 2020 at 7:01am
 
VS 2017
First, the VM license suddenly disappeared. After restoring the license, I did not see any of VM toolbars. If I try to add any VM toolbar it appears for a second and then disappears. The rest of the VS toolbars are added normally. Reinstalling the VM did not help.

What could be done?
Thanks in advance,
Vladimr
Back to top
« Last Edit: Sep 25th, 2020 at 7:04am by Kabron »  
 
IP Logged
 
Simon@Visual Micro
Administrator
*****
Offline



Posts: 502
Re: VM toolbars disappered.
Reply #1 - Sep 25th, 2020 at 9:59am
 
Thanks for the report.

If you go to the vMicro Menu:-
1) Are the options shown greyed out, and is there a "Try / Buy or Activate a Visual Micro License" option shown?
Help Re-Activating Visual Micro Software

2) If the options are available as normal, what is set in the vMicro > Toolbar Auto Visibility menu?
Automatic Toolbars in Visual Micro
Back to top
 
 
IP Logged
 
Kabron
Member
***
Offline



Posts: 133
Re: VM toolbars disappered.
Reply #2 - Sep 25th, 2020 at 1:11pm
 
It seems to appear only with TTGO-Watch board
Back to top
 
 
IP Logged
 
Visual Micro
Administrator
*****
Offline



Posts: 10893
United Kingdom
Re: VM toolbars disappered.
Reply #3 - Sep 25th, 2020 at 4:13pm
 
When windows is upgraded or the windows registry is lost then re-activation is required.

If the registry is lost then your settings will also be lost. In the past I think you have switched off "vMicro>Toolbar auto visibility". You need to switch it off again otherwise tool bars will only be visibile when an arduino project is active.
Back to top
 

Tim Leek
home
WWW  
IP Logged
 
Kabron
Member
***
Offline



Posts: 133
Re: VM toolbars disappered.
Reply #4 - Sep 25th, 2020 at 4:33pm
 
Thanks a lot, solved
Back to top
 
 
IP Logged
 
Simon@Visual Micro
Administrator
*****
Offline



Posts: 502
Re: VM toolbars disappered.
Reply #5 - Oct 2nd, 2020 at 3:03pm
 
Off-Topic replies have been moved to this Topic.
Back to top
 
 
IP Logged
 
Page Index Toggle Pages: 1
Send Topic Print