Welcome, Guest. Please Login or Register
Arduino IDE for Visual Studio
 
 
When Logging a Support Issue in the Forum, please ensure you have also:-
  • Enabled vMicro > Compiler > Show Build Properties and Verbose
  • Re-Compile your program with these settings enabled
 
Save the new Output to a Text File and....
  • Click the Reply button and attach as .txt file OR
  • Click here to Email us with the file attached, and a link to your post
Support requests without the output above may be impossible to answer, so please help us to help you
 
  HomeSearch Tutorials & Wiki visualmicro.com LoginHelpRegister  
 
Page Index Toggle Pages: 1
Send Topic Print
Compile error since gallery update 20.09.10.2 (Read 232 times)
horaciocastro7
Newbies
*
Offline



Posts: 6
Compile error since gallery update 20.09.10.2
Oct 7th, 2020 at 11:44pm
 
Desde ayer 06/Octubre/2020 que actualice el Vmicro dejo de compilarme, sale error que no encuentra una función pero ya la he revisado y esta correcto, al compilar en Ide de arduino 1.8.13 si compila sin problemas.

La versión que tengo del Vmicro la compre este año, no es gratuita
Back to top
« Last Edit: Oct 8th, 2020 at 12:27am by Visual Micro »  
 
IP Logged
 
Visual Micro
Administrator
*****
Offline



Posts: 10893
United Kingdom
Re: Error no compila en Vmicro pero en Ide Arduino Si
Reply #1 - Oct 7th, 2020 at 11:50pm
 
Hi

Please post in english in this forum thank you.

We need to see the error. Please follow the guide in the yellow box at the top of this page.

Thank you
Back to top
 

Tim Leek
home
WWW  
IP Logged
 
horaciocastro7
Newbies
*
Offline



Posts: 6
Re: Error no compila en Vmicro pero en Ide Arduino Si
Reply #2 - Oct 7th, 2020 at 11:56pm
 
Since yesterday 06 / October / 2020 that I update the Vmicro I stopped compiling, I get an error that it does not find a function but I have already reviewed it and it is correct, when compiling in Arduino Ide 1.8.13 if it compiles without problems.

I bought the version of the Vmicro this year, it is not free
Back to top
 

Please Register or Login to the Forum to see File Attachments
 
IP Logged
 
Visual Micro
Administrator
*****
Offline



Posts: 10893
United Kingdom
Re: Error no compila en Vmicro pero en Ide Arduino Si
Reply #3 - Oct 8th, 2020 at 12:27am
 
Thanks for the info

Please install the latest release from this forum here https://www.visualmicro.com/forums/YaBB.pl?board=VS_ARDUINO_EXT_RELEASES

If that is still a problem then please email the following file to us

C:\Users\Inso Blanco\AppData\Local\Temp\VMBuilds\I8\esp8266_d1_mini\Debug\I8.cpp

Thanks
Back to top
 

Tim Leek
home
WWW  
IP Logged
 
horaciocastro7
Newbies
*
Offline



Posts: 6
Re: Compile error since gallery update 20.09.10.2
Reply #4 - Oct 8th, 2020 at 3:31am
 

Download and install the update as you told me. restart visual studio and compile the problem as before.
Back to top
 
 
IP Logged
 
horaciocastro7
Newbies
*
Offline



Posts: 6
Re: Compile error since gallery update 20.09.10.2
Reply #5 - Oct 8th, 2020 at 2:48pm
 
Good morning. For now I have to use the arduino ide with Preferences (use external editor) to be able to use Visual Studio and I compile in the IDE de Arduino because Vmicro does not work. I hope they release a version soon that fixes this. thank you very much
Back to top
« Last Edit: Oct 8th, 2020 at 2:49pm by horaciocastro7 »  
 
IP Logged
 
Simon@Visual Micro
Administrator
*****
Offline



Posts: 502
Re: Compile error since gallery update 20.09.10.2
Reply #6 - Oct 8th, 2020 at 3:31pm
 
Can you please attach the file below, or alternatively email it to us (sales@visualmicro.com, include a link to this post in the email) so we can investigate the issue further:
Code:
C:\Users\Inso Blanco\AppData\Local\Temp\VMBuilds\I8\esp8266_d1_mini\Debug\I8.cpp 


Back to top
 
 
IP Logged
 
horaciocastro7
Newbies
*
Offline



Posts: 6
Re: Compile error since gallery update 20.09.10.2
Reply #7 - Oct 8th, 2020 at 7:26pm
 
I have already sent the data to the requested email. Thank you
Back to top
 
 
IP Logged
 
Simon@Visual Micro
Administrator
*****
Offline



Posts: 502
Re: Compile error since gallery update 20.09.10.2
Reply #8 - Oct 8th, 2020 at 9:09pm
 
Thanks for the information, and we will update when a fix is available.

To work around the issue in the meantime, removing the line break in the signatures of two functions should resolve the issue (venta_credito_ladox, venta_previo_ladox).

Example:
Code:
void aMultiLineSignature(int aVar,
			int anotherVar){ 



Becomes:
Code:
void aMultiLineSignature(int aVar, int anotherVar){ 



Back to top
 
 
IP Logged
 
horaciocastro7
Newbies
*
Offline



Posts: 6
Re: Compile error since gallery update 20.09.10.2
Reply #9 - Oct 8th, 2020 at 11:43pm
 

Thank you very much, the problem is solved. as I said before updating this did not happen. anyway it works for me without problems. thank you very much
Back to top
 
 
IP Logged
 
Simon@Visual Micro
Administrator
*****
Offline



Posts: 502
Re: Compile error since gallery update 20.09.10.2
Reply #10 - Oct 9th, 2020 at 11:18am
 
Thanks for confirming, and we have now released a new version containing this fix on the board below (20.09.10.7):
https://www.visualmicro.com/forums/YaBB.pl?board=VS_ARDUINO_EXT_RELEASES
Back to top
 
 
IP Logged
 
Page Index Toggle Pages: 1
Send Topic Print