Welcome, Guest. Please Login or Register
Arduino IDE for Visual Studio
 
 
When Logging a Support Issue in the Forum, please ensure you have also:-
  • Enabled vMicro > Compiler > Show Build Properties and Verbose
  • Re-Compile your program with these settings enabled
 
Save the new Output to a Text File and....
  • Click the Reply button and attach as .txt file OR
  • Click here to Email us with the file attached, and a link to your post
Support requests without the output above may be impossible to answer, so please help us to help you
 
  HomeSearch Tutorials & Wiki visualmicro.com LoginHelpRegister  
 
Page Index Toggle Pages: 1
Send Topic Print
BootUp time different using VisualMicro or Arduino (Read 60 times)
JoeLeTurbo
Newbies
*
Offline



Posts: 2
BootUp time different using VisualMicro or Arduino
Jan 13th, 2021 at 3:41pm
 
Hello,

I have some problems with the BootUp time with my Teensy 3.2

Here is my test sketch:
Code:
uint32_t Test;

void setup() {
	Test = millis();

	Serial.begin(115200);
	while (!Serial);
}

void loop() {
 
	delay(10000);                       // wait for 10 seconds
	Serial.println();
	Serial.print("BootTime: ");
	Serial.print(Test);
 Serial.print(" ms");
}
 



If I compile (Release mode) and upload it with VisualMicro I get a BootUp time of arround 4310 ms.
If i compile the same code in Arduino I get a boot up time of 300ms.

Where is the difference and how can I get the same BootTime?

I'm using VS2019 and VisualMicro V 2020.910.8

JoeLeTurbo
Back to top
« Last Edit: Jan 13th, 2021 at 3:42pm by JoeLeTurbo »  
 
IP Logged
 
Simon@Visual Micro
Administrator
*****
Offline



Posts: 628
Re: BootUp time different using VisualMicro or Arduino
Reply #1 - Jan 13th, 2021 at 3:48pm
 
Can you confirm you have the same board options set in both IDE's when comparing them?
(USB Type / CPU Speed / Optimize)

If they are the same please upload the full Build Output from both IDE's, with the below options set:
1) Visual Micro: Enable options > vMicro > Compiler > Show Build Properties and Verbose
2) Arduino IDE: Preferences > Show Verbose Output During Compilation [ticked]
Back to top
 
 
IP Logged
 
JoeLeTurbo
Newbies
*
Offline



Posts: 2
Re: BootUp time different using VisualMicro or Arduino
Reply #2 - Jan 15th, 2021 at 8:34pm
 
Yes, the board options were the same.

I reinstalled VisualMicro and now it works perfectly.
I now get the same boot up time in release version.
The debug version still takes 4310 ms but I think that is ok because of debug.

Thank you
Back to top
 
 
IP Logged
 
Page Index Toggle Pages: 1
Send Topic Print