Before logging an issue, please update to the latest release of Visual Micro from the Downloads Page.

When Logging a Support Issue in the Forum, please ensure you have also:-

  • Enabled vMicro > Compiler > Show Build Properties and Verbose
  • Re-Compile your program with these settings enabled
 
Save the new Output to a Text File and....
  • Click the Reply button and attach as .txt file OR
  • Click here to Email us with the file attached, and a link to your post
Support requests without the output above may be impossible to answer, so please help us to help you
 
Page Index Toggle Pages: 1 Send TopicPrint
Normal Topic Breakpoint in serial debugging does not show variable value (Read 586 times)
Egol
Junior Member
**
Offline


Posts: 16
Joined: May 17th, 2021
Breakpoint in serial debugging does not show variable value
Jun 1st, 2021 at 7:03am
Print Post  
Hello,
I'm working with the serial debugger and I can see the millis breakpoint data both on the Micro Debug Trace output as well as on the expression window.
I'm trying to add another break point that is doing the same thing with another variable but I can't get any output (See screenshot attached)
Thanks,
Eyal
  

Please Register or Login to the Forum to see File Attachments
Back to top
 
IP Logged
 
Tim@Visual Micro
Administrator
*****
Offline


Posts: 11676
Location: United Kingdom
Joined: Apr 10th, 2010
Re: Breakpoint in serial debugging does not show variable value
Reply #1 - Jun 1st, 2021 at 2:02pm
Print Post  
The serial/wifi debugger has to inject code into the temp build copy of the code. It injects onto the end of the code line which means inside an IF statement if the breakpoint is placed on an IF. 

In this case I suspect the IF statement the breakpoint is on resolved to false and therefore the breakpoint is not hit.

Because it is an injected code debugger you can move the breapoint up one line to an empty line if you need it to execute the breakpoint outside of the line you have selected.
  
Back to top
WWW  
IP Logged
 
Egol
Junior Member
**
Offline


Posts: 16
Joined: May 17th, 2021
Re: Breakpoint in serial debugging does not show variable value
Reply #2 - Jun 1st, 2021 at 7:01pm
Print Post  
Thank you! This was it! I moved it up a bit and I can see the variable value, Thanks! Smiley
  
Back to top
 
IP Logged
 
Page Index Toggle Pages: 1
Send TopicPrint