Welcome, Guest. Please Login or Register
Arduino IDE for Visual Studio
 
 

Before logging an issue, please update to the latest release of Visual Micro from the Downloads Page.

When Logging a Support Issue in the Forum, please ensure you have also:-

  • Enabled vMicro > Compiler > Show Build Properties and Verbose
  • Re-Compile your program with these settings enabled
 
Save the new Output to a Text File and....
  • Click the Reply button and attach as .txt file OR
  • Click here to Email us with the file attached, and a link to your post
Support requests without the output above may be impossible to answer, so please help us to help you
 
  HomeSearch Tutorials & Wiki visualmicro.com LoginHelpRegister  
 
Page Index Toggle Pages: 1
Send Topic Print
Switched projects - hardware debugging stopped working :( (Read 389 times)
HomerRamone
Junior Member
**
Offline



Posts: 38
Switched projects - hardware debugging stopped working :(
Feb 23rd, 2022 at 7:41pm
 
Having got the debugger working I thought I was all set.
I have a couple of projects in progress and was trying to track down a bug in one of them.

Previously ive build and run this project on a regular esp 32 and used serial debugging. But being able to BP a function and step will be super handy here.
So I switched over the boards and restarted VS.
Changed the settings for board and debugger.
No luck. Then I remembered board.txt. So I followed the same process of creating the file, pasted the text.
Added breakpoint and tried to debug.

Starts initializing the debugger then pops a dialog:
Back to top
 

Please Register or Login to the Forum to see File Attachments
 
IP Logged
 
Simon@Visual Micro
Administrator
*****
Offline



Posts: 1576
Re: Switched projects - hardware debugging stopped working :(
Reply #1 - Feb 24th, 2022 at 10:03am
 
Thanks for the report.

The Troubleshooting pages below may help identify the issue:
https://www.visualmicro.com/page/Troubleshooting-Debugging.aspx
https://www.visualmicro.com/page/Troubleshooter-for-Debugging-an-Arduino-Sketch-...

If not then please enable the below properties:
vMicro > Compiler > Verbose
vMicro > Compiler > Show Build Properties
vMicro > Uploader > Verbose

And then attach as text files the output from:
1) The Output > Micro Build Window, after completing a full build, and running Debug > Attach to Process
2) In the build folder there should be a log created <<projectname>>_OpenOCD.log
https://www.visualmicro.com/page/Troubleshooter-for-Debugging-an-Arduino-Sketch-...
Back to top
 
 
IP Logged
 
Page Index Toggle Pages: 1
Send Topic Print