Welcome, Guest. Please Login or Register
Arduino IDE for Visual Studio
 
 

Before logging an issue, please update to the latest release of Visual Micro from the Downloads Page.

When Logging a Support Issue in the Forum, please ensure you have also:-

  • Enabled vMicro > Compiler > Show Build Properties and Verbose
  • Re-Compile your program with these settings enabled
 
Save the new Output to a Text File and....
  • Click the Reply button and attach as .txt file OR
  • Click here to Email us with the file attached, and a link to your post
Support requests without the output above may be impossible to answer, so please help us to help you
 
  HomeSearch Tutorials & Wiki visualmicro.com LoginHelpRegister  
 
Pages: 1 2 
Send Topic Print
ESP Prog / LilyGO-TTGO-T-Display (16MB ESP32) : JTAG scan chain interrogation failed: all one (Read 2167 times)
Simon@Visual Micro
Administrator
*****
Offline



Posts: 1459
Re: ESP Prog / LilyGO-TTGO-T-Display (16MB ESP32) : JTAG scan chain interrogation failed: all one
Reply #20 - Apr 28th, 2022 at 4:27pm
 
Thanks for the update and I believe I have found an issue in how the commands are manipulated in the new gdb tooling system.

If you change your board.txt, and replace the two debug entries with the below, does this allow the debugging to begin?
Code:
# Debugger Patterns
 debug.gdbscript.adapter_khz=2000
 tools.openocd.debug.path={runtime.tools.openocd-esp32-0.10.1-2021.11.11.path}
 tools.openocd.debug.args={params.verbose} -l "{{build.path}/{build.project_name}_DebugOpenOCD.log}" -s "{path}/share/openocd/scripts/" -f "{path}/share/openocd/scripts/interface/{build.openocddebugger}" -c "set ESP32_RTOS none" -f "{path}/share/openocd/scripts/board/{openocdscript}" {initCmd} 

Back to top
 
 
IP Logged
 
Chris2N
Junior Member
**
Offline



Posts: 20
Re: ESP Prog / LilyGO-TTGO-T-Display (16MB ESP32) : JTAG scan chain interrogation failed: all one
Reply #21 - Apr 28th, 2022 at 5:01pm
 
unfortunately it is not working. The behaviour seems to be unchanged: Upload via Serial & ESP-Prog works, but Hardware Debugging fails (Launch options string-Error again)

Attaching adds only this line to the output (as before)
Using project build property overrides from E:\Eigene Dateien\Quelltexte\Arduino\Arduino\ESP32\OfenSteuerung\board.txt
Back to top
 

Please Register or Login to the Forum to see File Attachments
 
IP Logged
 
Chris2N
Junior Member
**
Offline



Posts: 20
Re: ESP Prog / LilyGO-TTGO-T-Display (16MB ESP32) : JTAG scan chain interrogation failed: all one
Reply #22 - Apr 29th, 2022 at 6:41pm
 
Problem was solvedĀ  Smiley with help of Simon and the debugger patterns he gave. (Many thanks!)
I attach the boards.txt that finally worked for me in Visual Micro 2022.218.2205 and 2022.429.2200

One contribution to the problem was also, that I didn't hadĀ  the option
Visual Micro > Debugger set to Debug: Hardware in all relevant projects.

PS: Also worked with my other batch of TTGOs (DOWDQ5 CPU, the Batch I tried first was DOWDQ6) and leaving D6 in place.
(Simplified Cabeling mentioned by kiromaisus: https://github.com/Xinyuan-LilyGO/TTGO-T-Display/issues/6#issuecomment-899104385
)

See also attached photo. (If you do the same, don't forget to insulate the header pin used for GPIO 14 against the ground conector on that place on the board e.g. with a piece of shrink tube.)
Back to top
« Last Edit: May 4th, 2022 at 2:48pm by Chris2N »  

Please Register or Login to the Forum to see File Attachments
 
IP Logged
 
Simon@Visual Micro
Administrator
*****
Offline



Posts: 1459
Re: ESP Prog / LilyGO-TTGO-T-Display (16MB ESP32) : JTAG scan chain interrogation failed: all one
Reply #23 - May 6th, 2022 at 4:50pm
 
We have released an updated version (22.04.29-1) which should work correctly with a pattern containing -c "adapter_khz 2000" , which is available from the top of the board below:
https://www.visualmicro.com/forums/YaBB.pl?board=VS_ARDUINO_EXT_RELEASES
Back to top
 
 
IP Logged
 
Pages: 1 2 
Send Topic Print