Welcome, Guest. Please Login or Register
Arduino IDE for Visual Studio
 
 

Before logging an issue, please update to the latest release of Visual Micro from the Downloads Page.

When Logging a Support Issue in the Forum, please ensure you have also:-

  • Enabled vMicro > Compiler > Show Build Properties and Verbose
  • Re-Compile your program with these settings enabled
 
Save the new Output to a Text File and....
  • Click the Reply button and attach as .txt file OR
  • Click here to Email us with the file attached, and a link to your post
Support requests without the output above may be impossible to answer, so please help us to help you
 
  HomeSearch Tutorials & Wiki visualmicro.com LoginHelpRegister  
 
Page Index Toggle Pages: 1
Send Topic Print
Debugger starting but debug is OFF (Read 157 times)
emha69
Newbies
*
Offline



Posts: 1
Debugger starting but debug is OFF
Jul 21st, 2022 at 10:00am
 
Hi,

pretty annoying is that, if the COM window is open, but debug mode is OFF, the VSM still attempts to start the debugger.

I would expect that, if debug mode is OFF, the debugger is not initiated. This is the case on old VS2019 and current VS2022 versions. This also leads to diverse side effects, such as blocked COM port in some cases that prevents uploading etc.
Back to top
 
 
IP Logged
 
Tim@Visual Micro
Administrator
*****
Offline



Posts: 11537
United Kingdom
Re: Debugger starting but debug is OFF
Reply #1 - Jul 23rd, 2022 at 12:18am
 
You can either switch to a Release configuration or switch off vMicro>Debugger>Automatic Debugging. The automatic option auto enables/disables the serial debugger based on the configuration (Release/debug), see the main tool bar.
Back to top
 

Tim Leek
home
WWW  
IP Logged
 
Page Index Toggle Pages: 1
Send Topic Print