Welcome, Guest. Please Login or Register
Arduino IDE for Visual Studio
 
 

Before logging an issue, please update to the latest release of Visual Micro from the Downloads Page.

When Logging a Support Issue in the Forum, please ensure you have also:-

  • Enabled vMicro > Compiler > Show Build Properties and Verbose
  • Re-Compile your program with these settings enabled
 
Save the new Output to a Text File and....
  • Click the Reply button and attach as .txt file OR
  • Click here to Email us with the file attached, and a link to your post
Support requests without the output above may be impossible to answer, so please help us to help you
 
  HomeSearch Tutorials & Wiki visualmicro.com LoginHelpRegister  
 
Page Index Toggle Pages: 1
Send Topic Print
Option to disable --relax (Read 7093 times)
swordfishBob
Newbies
*
Offline



Posts: 9
Option to disable --relax
May 27th, 2013 at 6:39am
 
I'm having some problems that appear to relate to a linker bug involving --relax.  Can we have an option to disable use of --relax, or is there another way to do this?
Back to top
 
 
IP Logged
 
Tim@Visual Micro
Administrator
*****
Offline



Posts: 11487
United Kingdom
Re: Option to disable --relax
Reply #1 - May 27th, 2013 at 5:26pm
 
I have just altered vm so the next release (week or so) will allow a board property of:-

Code:
build.linker_relaxation=false 



in the current build for arduino versions below 1.5 the relax is forced on for the 2560 chip or if build.linker_relaxation=true

so that doesn't help you right now, but you can try build 1305.21 from our beta channel along with arduino 1.5.2

I notice in 1.5.2 the relax option is not hard coded, it is set using the boards.txt and platforms.txt in the ide/hardware/arduino/... folder

1.5x is beta but I think it works okay for avr chips so you could give it a try and create your own custom board def. do you know how to do that?






Back to top
 

Tim Leek
home
WWW  
IP Logged
 
swordfishBob
Newbies
*
Offline



Posts: 9
Re: Option to disable --relax
Reply #2 - May 27th, 2013 at 10:44pm
 
Thanks for the advice, I can have a go. I'll be tied up for a few days and temporarily get around the problem by containing the total size of my code and progmem strings.
Back to top
 
 
IP Logged
 
swordfishBob
Newbies
*
Offline



Posts: 9
Re: Option to disable --relax
Reply #3 - Jun 7th, 2013 at 5:52am
 
Attempting.. I have 13.05.21 and Arduino 1.5.2
The VM/VS environment can't find the libraries (e.g. <Ethernet.h>). How do I resolve this?
Back to top
 
 
IP Logged
 
Tim@Visual Micro
Administrator
*****
Offline



Posts: 11487
United Kingdom
Re: Option to disable --relax
Reply #4 - Jun 7th, 2013 at 12:21pm
 
Yes the hardware libs will be supported in the next release of Visual Micro

For now you can move the subfolder in "[arduino-1.5.2]\hardware\arduino\avr\libraries" to "[arduino-1.5.2]\libraries"
Back to top
 

Tim Leek
home
WWW  
IP Logged
 
swordfishBob
Newbies
*
Offline



Posts: 9
Re: Option to disable --relax
Reply #5 - Jun 7th, 2013 at 10:56pm
 
Thanks.
I got it compiling with 1.5.2, without removing the relax flag, hopefully it means the bug in pointer relaxation (in the linker) has actually been fixed.
To compile, I had to edit the various .cpp's in the Ethernet lib so they would find w5100.h and socket.h as utility/w5100.h and utility/socket.h; or I probably could have copied socket and w5100 back a level into libraries/Ethernet. I guess you've encountered that..?
Back to top
 
 
IP Logged
 
Tim@Visual Micro
Administrator
*****
Offline



Posts: 11487
United Kingdom
Re: Option to disable --relax
Reply #6 - Jun 8th, 2013 at 6:29pm
 
I think you can just grab the libs from an earlier arduino version such as 1.0.4

There will be a new Visual Micro version shortly.

Thanks
Back to top
 

Tim Leek
home
WWW  
IP Logged
 
Page Index Toggle Pages: 1
Send Topic Print