Welcome, Guest. Please Login or Register
Arduino IDE for Visual Studio
 
 
When Logging a Support Issue in the Forum, please ensure you have also:-
  • Enabled vMicro > Compiler > Show Build Properties and Verbose
  • Re-Compile your program with these settings enabled
 
Save the new Output to a Text File and....
  • Click the Reply button and attach as .txt file OR
  • Click here to Email us with the file attached, and a link to your post
Support requests without the output above may be impossible to answer, so please help us to help you
 
  HomeSearch Tutorials & Wiki visualmicro.com LoginHelpRegister  
 
Page Index Toggle Pages: 1
Send Topic Print
Forcing rebuild (Read 6650 times)
andrewf
Newbies
*
Offline



Posts: 6
Forcing rebuild
Jun 2nd, 2013 at 2:49pm
 
I downloaded the latest AC3.0 code (RC4) and couldn't get it to build in VS2012 using VisualMicro 1.1305.09. Errors were:
   AP_Baro.cpp.o : : In Function 'AP_ParamT<float, (ap_var_type)4::set_and_save(float ...
   AP_Param.h : save()'
   AP_Param.h : save()'
   AC_Fence.cpp.o : : In Function 'AP_ParamT<float, (ap_var_type)4::set_and_save(float ...
   AP_Param.h : save()'
   AP_Param.h : save()'   
   Error creating .elf


I ended up resolving this by opening then saving the AP_Baro.h and AC_Fence.h files and then the build worked fine. I figure I forced it to see a change that needed a library to be rebuilt. Does this make sense as an explanation? Is there any way I can force a complete re-build just to make sure I have captured any changes? I am concerned that there may have been other code changes that did not result in build errors, but which I am missing.

Thank you,
Andrew
Back to top
 

Please Register or Login to the Forum to see File Attachments
 
IP Logged
 
Visual Micro
Administrator
*****
Offline



Posts: 10706
United Kingdom
Re: Forcing rebuild
Reply #1 - Jun 2nd, 2013 at 3:20pm
 
Project menu build clean should work. I'll look into why the changes were not auto detected
Back to top
 

Please Register or Login to the Forum to see File Attachments
WWW  
IP Logged
 
andrewf
Newbies
*
Offline



Posts: 6
Re: Forcing rebuild
Reply #2 - Jun 2nd, 2013 at 3:48pm
 
Thank you Tim.

I should have mentioned that I didn't start from a fresh project.  I merged the latest commits from the git repository and tried to rebuild. 

Andrew
Back to top
 

Please Register or Login to the Forum to see File Attachments
 
IP Logged
 
Visual Micro
Administrator
*****
Offline



Posts: 10706
United Kingdom
Re: Forcing rebuild
Reply #3 - Jun 2nd, 2013 at 3:52pm
 
Okay I see that is a bit off the wall and maybe the build>clean is the best solution for you.

Thanks
Back to top
 

Please Register or Login to the Forum to see File Attachments
WWW  
IP Logged
 
andrewf
Newbies
*
Offline



Posts: 6
Re: Forcing rebuild
Reply #4 - Jun 2nd, 2013 at 4:28pm
 
No big deal for me to do the clean build if that is what is needed.  If I have similar problems later on I will start with that.

Thanks again,
Andrew
Back to top
 

Please Register or Login to the Forum to see File Attachments
 
IP Logged
 
Visual Micro
Administrator
*****
Offline



Posts: 10706
United Kingdom
Re: Forcing rebuild
Reply #5 - Jun 2nd, 2013 at 5:46pm
 
Thanks and well spotted!
Back to top
 

Please Register or Login to the Forum to see File Attachments
WWW  
IP Logged
 
Page Index Toggle Pages: 1
Send Topic Print