Welcome, Guest. Please Login or Register
Arduino IDE for Visual Studio
 
 
When Logging a Support Issue in the Forum, please ensure you have also:-
  • Enabled vMicro > Compiler > Show Build Properties and Verbose
  • Re-Compile your program with these settings enabled
 
Save the new Output to a Text File and....
Support requests without the output above may be impossible to answer, so please help us to help you
 
  HomeSearch Tutorials & Wiki visualmicro.com LoginHelpRegister  
 
Page Index Toggle Pages: 1
Send Topic Print
Interrupts and Crumbuino-128 (Read 2398 times)
BeagleBot
Junior Member
**
Offline



Posts: 14
Interrupts and Crumbuino-128
Jul 8th, 2015 at 11:46am
 
Hello, all.

I use an Crumbuino 128 from chip45.com and I have a strange problem with the interrupts
when I connect two quadrant encoders on port 4 - 7 and 5 - 6 then I must use the INT4 and INT5
to handle the interrupts right!

But this are not working it's only worked with INT0 and INT1

Code:

const int aEncMtrL = 4;        //INT4 interrupt pin
const int bEncMtrL = 7;        //determines the direction of travel
const int aEncMtrR = 5;        //INT5 interrupt pin
const int bEncMtrR = 6;        //determines the direction of travel

attachInterrupt(INT4, encoderISR_L, RISING);   this must by working but it doesn't
attachInterrupt(INT5, encoderISR_R, RISING);

attachInterrupt(INT0, encoderISR_L, RISING);   this working but it's not the right way   
attachInterrupt(INT1, encoderISR_R, RISING);

can someone help my with this were I can find an solution for this.

thanx.
Back to top
 
 
IP Logged
 
Visual Micro
Administrator
*****
Offline



Posts: 10340
United Kingdom
Re: Interrupts and Crumbuino-128
Reply #1 - Jul 8th, 2015 at 11:48am
 
Hi,

I think the best answer will come from here http://arduino.cc/forum

Regards
Back to top
 
WWW  
IP Logged
 
Page Index Toggle Pages: 1
Send Topic Print