Welcome, Guest. Please Login or Register
Arduino IDE for Visual Studio
 
 
When Logging a Support Issue in the Forum, please ensure you have also:-
  • Enabled vMicro > Compiler > Show Build Properties and Verbose
  • Re-Compile your program with these settings enabled
 
Save the new Output to a Text File and....
Support requests without the output above may be impossible to answer, so please help us to help you
 
  HomeSearch Tutorials & Wiki visualmicro.com LoginHelpRegister  
 
Page Index Toggle Pages: 1
Send Topic Print
Can not find file when adding library to code (Read 439 times)
Waleed El-Badry
Newbies
*
Offline


Waleed El-Badry

Posts: 9
Egypt
Can not find file when adding library to code
Mar 14th, 2019 at 11:04pm
 
Hello,
Whenever I try to add any library using Add library from the menu, it is always highlighted in red and thus I can not use intellisense for methods completion. The code can be compiled if functions were written correctly. Also if I close the project and reopen it, the library is recognized.

I tried rescan toolchain but unfortunately it is not able to detect any inserted new libraries unless I close the project. Any help is appreciated. Thanks

...
Back to top
 

--------------------------------------------
Waleed El-Badry MSc., MCPD , CLAD
PhD Candidate, Assistant lecturer in Mechatronics Department
Misr University for Science and Technology
Waleed El-Badry wbadry  
IP Logged
 
Visual Micro
Administrator
*****
Offline



Posts: 10526
United Kingdom
Re: Can not find file when adding library to code
Reply #1 - Mar 16th, 2019 at 12:04pm
 
I haven't seen this before where the solution has to be closed before intellisense re-validates the c++ project.

Questions

1) Which version of visual studio 2017 are you using. You can see the full build/version number in help>about

2) If you have two projects in your solution and add a library to one of them does the problem resolve itself?

Thanks
Back to top
 
WWW  
IP Logged
 
TheStallionMang
Junior Member
**
Offline



Posts: 12
Re: Can not find file when adding library to code
Reply #2 - Jun 14th, 2019 at 8:04pm
 
Tim - feel free to delete this comment if it confuses things, but this happens to me pretty often (VS 2017 15.7.5) and I just clean and rebuild the solution, and then everything works great again.
Back to top
 
 
IP Logged
 
Visual Micro
Administrator
*****
Offline



Posts: 10526
United Kingdom
Re: Can not find file when adding library to code
Reply #3 - Jun 14th, 2019 at 10:26pm
 
Okay I will check the cache update after compile.
Back to top
 
WWW  
IP Logged
 
Visual Micro
Administrator
*****
Offline



Posts: 10526
United Kingdom
Re: Can not find file when adding library to code
Reply #4 - Jun 22nd, 2019 at 11:30pm
 
Hi both,

I think this is resolved in the latest 1906.22+ releases. There was an issue with stale cache after closing an Arduino project in VS then opening a different project that had existing build cache.

Thanks again for the reports!

Download 1906.22 is currently here
https://www.visualmicro.com/forums/YaBB.pl?board=VS_ARDUINO_EXT_RELEASES


Back to top
« Last Edit: Jun 22nd, 2019 at 11:31pm by Visual Micro »  
WWW  
IP Logged
 
Page Index Toggle Pages: 1
Send Topic Print