Welcome, Guest. Please Login or Register
Arduino IDE for Visual Studio
 
 
When Logging a Support Issue in the Forum, please ensure you have also:-
  • Enabled vMicro > Compiler > Show Build Properties and Verbose
  • Re-Compile your program with these settings enabled
 
Save the new Output to a Text File and....
Support requests without the output above may be impossible to answer, so please help us to help you
 
  HomeSearch Tutorials & Wiki visualmicro.com LoginHelpRegister  
 
Page Index Toggle Pages: 1
Send Topic Print
vMicro (Read 204 times)
roryK1
Newbies
*
Offline



Posts: 1
vMicro
Dec 10th, 2019 at 8:03pm
 
Hi ,
I am having trouble getting the debugger work with the following setup:
visual studio 2019
vMicro
Atmel ICE.
I can get the release and debug hex file to upload to target using the Atmel ICE but when I go to launch the local debugger I get a popup saying that myapplicaton.exe file is not found in target folder.
The file prompted for is myapplication.exe. I would have thought that it would be running myapplication.hex.
Is there some setting that I am missing to run the debug file?


Back to top
 
 
IP Logged
 
Simon Hopkinson
Administrator
*****
Offline



Posts: 186
Re: vMicro
Reply #1 - Dec 11th, 2019 at 9:16am
 
Have you selected the "vMicro > Debug > Type: Hardware" option?

Then it should allow the Atmel ICE to be chosen as a debugger.

Once selected pressing Debug > Start should run the correct actions and it should not be looking for an EXE.

These can be seen on the below page:
https://www.visualmicro.com/page/SAM-Debugging.aspx

If the issue persists with the EXE warning after correcting the other options, try creating a new project and setting the options again, and cloning the code into it.



Back to top
 
 
IP Logged
 
Page Index Toggle Pages: 1
Send Topic Print