Welcome, Guest. Please Login or Register
Arduino IDE for Visual Studio
 
 
When Logging a Support Issue in the Forum, please ensure you have also:-
  • Enabled vMicro > Compiler > Show Build Properties and Verbose
  • Re-Compile your program with these settings enabled
 
Save the new Output to a Text File and....
Support requests without the output above may be impossible to answer, so please help us to help you
 
  HomeSearch Tutorials & Wiki visualmicro.com LoginHelpRegister  
 
Page Index Toggle Pages: 1
Send Topic Print
Verify upload doesnt work (Read 697 times)
deafzor
Newbies
*
Offline



Posts: 2
Verify upload doesnt work
Nov 9th, 2018 at 12:21pm
 
I turned off vMicro->Uploader->Verify but the output when using verbose-flag in compiler section still shows
that it's reading on-chip-flash data and verifying contents

Is this related to compiler-verbose flag and is there some way to turn off verification completely?
Back to top
« Last Edit: Nov 9th, 2018 at 2:28pm by Visual Micro »  
 
IP Logged
 
Visual Micro
Administrator
*****
Offline



Posts: 9917
United Kingdom
Re: Verify upload doesnt work
Reply #1 - Nov 9th, 2018 at 2:30pm
 
Please switch on vmicro>compiler>verbose and also "show build properties"

Then build and copy the output into a .txt file. Then attach to a post here (you have to click reply to attach a file to a post you probably can't use the quick reply at the bottom of this page.
Back to top
 
WWW  
IP Logged
 
deafzor
Newbies
*
Offline



Posts: 2
Re: Verify upload doesnt work
Reply #2 - Nov 9th, 2018 at 5:16pm
 
I can testify that verify checkbox is turned off in uploader before and after dump
Back to top
 
 
IP Logged
 
Visual Micro
Administrator
*****
Offline



Posts: 9917
United Kingdom
Re: Verify upload doesnt work
Reply #3 - Nov 10th, 2018 at 12:14pm
 
Add a board.txt to the project with this line in it

tools.avrdude.upload.verify=-V
Back to top
« Last Edit: Nov 10th, 2018 at 12:14pm by Visual Micro »  
WWW  
IP Logged
 
Hartmut
Junior Member
**
Offline



Posts: 9
Re: Verify upload doesnt work
Reply #4 - Apr 9th, 2019 at 12:16pm
 
Have the same problem. board.txt solution sounds interesting and easy to apply.
Can you please specify the exact location? With me nothing of
- one-line board.txt next to the .ino file
- inside <Installation folder>\hardware\arduino\avr\boards.txt
- inside <Installation folder>\hardware\arduino\avr\platform.txt
works  Undecided

Thank you very much for your answer!

VS 2017
Arduino IDE 1.8.7
Win 10 V1809
Arduino Nano w/ ATMega328P (Old Bootloader)
Back to top
 
 
IP Logged
 
Visual Micro
Administrator
*****
Offline



Posts: 9917
United Kingdom
Re: Verify upload doesnt work
Reply #5 - Apr 9th, 2019 at 1:39pm
 
What is in your board.txt in the local project? (we are not interested in boards.txt)

Did you email the verbose output with "show build properties" to visual micro with link to this thread? The output shows what has been discovered.


Back to top
 
WWW  
IP Logged
 
Hartmut
Junior Member
**
Offline



Posts: 9
Re: Verify upload doesnt work
Reply #6 - Apr 9th, 2019 at 3:35pm
 
Thanks for your quick response!
Before, I had no board.txt at all. After reading this thread, I added a board.txt to the same folder as the .ino file, containing only the line "tools.avrdude.upload.verify=-V" you answered to deafzor, as stated above. The line is terminated by the enter key.

BTW: My 'Arduino IDE for Visual Studio' version is 1903.24.2

Back to top
 
 
IP Logged
 
Visual Micro
Administrator
*****
Offline



Posts: 9917
United Kingdom
Re: Verify upload doesnt work
Reply #7 - May 19th, 2019 at 11:41pm
 
There has been an update to the verify which will especially help avr boards. The release is here
https://www.visualmicro.com/forums/YaBB.pl?board=VS_ARDUINO_EXT_RELEASES
Back to top
 
WWW  
IP Logged
 
Page Index Toggle Pages: 1
Send Topic Print