Welcome, Guest. Please Login or Register
Arduino IDE for Visual Studio
 
 
When Logging a Support Issue in the Forum, please ensure you have also:-
  • Enabled vMicro > Compiler > Show Build Properties and Verbose
  • Re-Compile your program with these settings enabled
 
Save the new Output to a Text File and....
Support requests without the output above may be impossible to answer, so please help us to help you
 
  HomeSearch Tutorials & Wiki visualmicro.com LoginHelpRegister  
 
Page Index Toggle Pages: 1
Send Topic Print
ESP Tool Missing when uploading spiffs (Read 515 times)
davidbal
Junior Member
**
Offline



Posts: 18
ESP Tool Missing when uploading spiffs
May 13th, 2019 at 11:55pm
 
ESP8266 SPIFF file upload was working in VS2017 for me, but I reinstalled the Arduino IDE to try and fix a problem with ESP8266 mDNS. Now when I try to upload SPIFFS I get this message:
ESP8266FSUpload.exe

SPIFFS Error*: esptool not found!

I can see the ESP8266FSUpload.exe in the VS directories.
I tried VS2019 and get the same error.

Is esptools meant to be an .exe or .py file?

Not sure what has happened to stop it working. It works fine in the Arduino IDE.

Regards,

David
Back to top
 
 
IP Logged
 
Visual Micro
Administrator
*****
Offline



Posts: 10339
United Kingdom
Re: ESP Tool Missing when uploading spiffs
Reply #1 - May 14th, 2019 at 12:00am
 
There was a change recently because the esp core changed how it works however it shouldn't break. Please follow the guide at the top of the forum and provide build output so we can see which esp version and, board etc you have installed.
Back to top
 
WWW  
IP Logged
 
davidbal
Junior Member
**
Offline



Posts: 18
Re: ESP Tool Missing when uploading spiffs
Reply #2 - May 14th, 2019 at 10:28am
 
Could you give me a link to the guide you are referring to, so I can make sure I am following the correct one..

Thank you...

Regards,

David
Back to top
 
 
IP Logged
 
Simon Hopkinson
Administrator
*****
Offline



Posts: 36
Re: ESP Tool Missing when uploading spiffs
Reply #3 - May 15th, 2019 at 9:51am
 
Hi David,

Its the message at the top of all forum pages, and it will aid greatly in finding the root cause of this issue if you can supply this information.

Instructions:
Enabled vMicro > Compiler > Show Build Properties and Verbose

Re-Compile your program with these settings enabled

Save the new Output to a Text File and....

Attach it to your post
OR
Email us with the file attached, and a link to your post

Thanks

Simon
Back to top
 
 
IP Logged
 
davidbal
Junior Member
**
Offline



Posts: 18
Re: ESP Tool Missing when uploading spiffs
Reply #4 - May 15th, 2019 at 9:14pm
 
OK I see it now, I was looking in the forum list for the information...perhaps it could be made to stand out better...

Actually, perhaps you could put that info in the white space to the right of the text input box...if the software will allow that..?

Anyway, I saw the comment in another forum message..and have provided the requested information.

Best regards,

David
Back to top
« Last Edit: May 15th, 2019 at 9:15pm by davidbal »  
 
IP Logged
 
Visual Micro
Administrator
*****
Offline



Posts: 10339
United Kingdom
Re: ESP Tool Missing when uploading spiffs
Reply #5 - May 15th, 2019 at 9:37pm
 
All we actually need to know if what esp version you have installed in board manager then we can test.

Someone emailed to say that the 2.5.1 esp update is when the issue started so if that is what you are using you can drop back to 2.5.0.

We will test with 2.5.1 over the next week or so.
Back to top
 
WWW  
IP Logged
 
davidbal
Junior Member
**
Offline



Posts: 18
Re: ESP Tool Missing when uploading spiffs
Reply #6 - May 15th, 2019 at 10:36pm
 
I upgraded to 2.5.1 to see if it fixed a problem with mDNS failing intermittently. It didn't! So I have now downgraded to 2.5.0 and the SPiffs upload is working again in Visual Micro.

Thanks for the help.

Best regards,

David

Back to top
 
 
IP Logged
 
Visual Micro
Administrator
*****
Offline



Posts: 10339
United Kingdom
Re: ESP Tool Missing when uploading spiffs
Reply #7 - May 16th, 2019 at 12:53am
 
Thanks we found a note from the manufacturers about this change and will implement over the coming weeks.

https://arduino-esp8266.readthedocs.io/en/2.5.1/filesystem.html#uploading-files-...

When posting it's always handy to state versions of cores especially if recently upgrade.

Thanks for the report.
Back to top
 
WWW  
IP Logged
 
Visual Micro
Administrator
*****
Offline



Posts: 10339
United Kingdom
Re: ESP Tool Missing when uploading spiffs
Reply #8 - May 19th, 2019 at 1:01pm
 
There is an update that resolves a few issues with the latest esp 2.5.1 cores. Available in our new releases forum.

https://www.visualmicro.com/forums/YaBB.pl?board=VS_ARDUINO_EXT_RELEASES

Thanks for the report.


Back to top
« Last Edit: May 19th, 2019 at 5:58pm by Visual Micro »  
WWW  
IP Logged
 
Page Index Toggle Pages: 1
Send Topic Print