Welcome, Guest. Please Login or Register
Arduino IDE for Visual Studio
 
 
When Logging a Support Issue in the Forum, please ensure you have also:-
  • Enabled vMicro > Compiler > Show Build Properties and Verbose
  • Re-Compile your program with these settings enabled
 
Save the new Output to a Text File and....
Support requests without the output above may be impossible to answer, so please help us to help you
 
  HomeSearch Tutorials & Wiki visualmicro.com LoginHelpRegister  
 
Page Index Toggle Pages: 1
Send Topic Print
Imported Arduino project with Atmel start project not working (Read 274 times)
Mubashar Ali
Newbies
*
Offline



Posts: 4
Imported Arduino project with Atmel start project not working
Oct 2nd, 2019 at 9:14pm
 


I basically combining two projects one built in Atmel Studio 7.0 using atmel start and other is imported from Arduino both projects are working and compiling perfectly independently in solution but when i copy code and files to other project it did not recognize the included file even it is pointing the right file (by right click and click go to implementation) i don't know how to figure out

i also try to edit the *.cppproj , *.cproj and *.xml files but i did not work
also try to link with one another but in wane,
i might be missing something but i don't know what

one reason i think is here, that one project is using C compiler or linker what so ever is called and other project is using Cpp compiler or linker
Back to top
 
 
IP Logged
 
Visual Micro
Administrator
*****
Offline



Posts: 10623
United Kingdom
Re: Imported Arduino project with Atmel start project not working
Reply #1 - Oct 2nd, 2019 at 9:23pm
 
Hi, I am not sure you are using any Visual Micro Arduino functionality. Atmel confused things some time ago when they released an Arduino importer. That converts arduino to cpp projects and does not use .ino files. This can diserable for some advanced users but moves away from Arduino.

If you do not have a project_name.ino in a project_name.cppproj in a folder of project_name then you certainly are not using Visual Micro.

For Arduino, we generally recommend vs2017 or 2019 with Visual Micro because the IDEs are more mature and Visual Micro offers more features.

Back to top
« Last Edit: Oct 2nd, 2019 at 9:26pm by Visual Micro »  
WWW  
IP Logged
 
Mubashar Ali
Newbies
*
Offline



Posts: 4
Re: Imported Arduino project with Atmel start project not working
Reply #2 - Oct 2nd, 2019 at 9:28pm
 
Thanks for replay
i am not using micro importer or module in Atmel Studio 7
i used atmel builtin function to import
and those are .cppproj and .cpp file

the reason i import to AS7 is that i need to use Qtouch with is only accessible through AS and unfortunalyy thay clam that our all atmel start functions are in C language, CPP is not supported yet.
Back to top
 
 
IP Logged
 
Visual Micro
Administrator
*****
Offline



Posts: 10623
United Kingdom
Re: Imported Arduino project with Atmel start project not working
Reply #3 - Oct 2nd, 2019 at 9:34pm
 
If you follow the guide in yellow at the top of this page we will see if Visual Micro is making an Arduino compile or not. I suspect not, in which case your question is best answered by microchip on their support site.

Even if you are using arduino the import probably is unrelated. Arduino requires sources in the project folder, \src sub folder or any folder structure below the \src folder. To use external code Arduino would use libraries which are different to the atmel libraries.

In a visual micro project we can not prevent atmel studio from adding a Libraries node to the project, however the standard arduino build definitions have no way to use the atmel libraries. Visual Micro does allow .a files to be placed in a \libs folder otherwise you can use .c files but must be quite familiar with arduino code to use .c files.

If you want to create and compile a new simple project "file>new>arduino project" you will see what an arduino build looks like compared to an atmel build.
Back to top
 
WWW  
IP Logged
 
Mubashar Ali
Newbies
*
Offline



Posts: 4
Re: Imported Arduino project with Atmel start project not working
Reply #4 - Oct 2nd, 2019 at 9:40pm
 
oh you thing my arduino project is not compiling it is
the problem is not about compling the project

problem is how to link two different projects while one is cpp and other is c

how every i try to go with Visual micro, this way i might get problem solve, i will come back with results
Back to top
 
 
IP Logged
 
Visual Micro
Administrator
*****
Offline



Posts: 10623
United Kingdom
Re: Imported Arduino project with Atmel start project not working
Reply #5 - Oct 2nd, 2019 at 9:46pm
 
I think it is a question for the arduino.cc forum or the microchip forum. I can tell you that arduino and visual micro will not use the xml file and all other sourvces that need to be compiled (cpp/h) must fall into the allowed folder paths.

If you want it to work in Visual Micro then it should also work in the arduino ide.

Back to top
« Last Edit: Oct 2nd, 2019 at 9:47pm by Visual Micro »  
WWW  
IP Logged
 
Mubashar Ali
Newbies
*
Offline



Posts: 4
Re: Imported Arduino project with Atmel start project not working
Reply #6 - Oct 2nd, 2019 at 10:28pm
 
i sorry to say that visual micro arduino code is working perfectly, can any one tell that how i can include atmel start project which is actually Qtouch based, can be imported
Back to top
 
 
IP Logged
 
Visual Micro
Administrator
*****
Offline



Posts: 10623
United Kingdom
Re: Imported Arduino project with Atmel start project not working
Reply #7 - Oct 3rd, 2019 at 12:24pm
 
Please provide the info requested in the yellow box above. It allows us to see what can't be found. You can see that info but we can't and you have not provided it.
Back to top
 
WWW  
IP Logged
 
Page Index Toggle Pages: 1
Send Topic Print