Welcome, Guest. Please Login or Register
Arduino IDE for Visual Studio
 
 
When Logging a Support Issue in the Forum, please ensure you have also:-
  • Enabled vMicro > Compiler > Show Build Properties and Verbose
  • Re-Compile your program with these settings enabled
 
Save the new Output to a Text File and....
  • Click the Reply button and attach as .txt file OR
  • Click here to Email us with the file attached, and a link to your post
Support requests without the output above may be impossible to answer, so please help us to help you
 
  HomeSearch Tutorials & Wiki visualmicro.com LoginHelpRegister  
 
Page Index Toggle Pages: 1
Send Topic Print
Upload Error with Pololu A-Star Board (Read 512 times)
wep
Newbies
*
Offline



Posts: 5
Upload Error with Pololu A-Star Board
Jan 31st, 2020 at 11:38am
 
Hi,
I installed the Pololu A-Star Board which is a 328PB but it will not upload via VM.  It does upload no problem with the Arduino IDE.  I've attached the Verbose upload from both.
Any Ideas??
Thanks, -Bill
Back to top
 

Please Register or Login to the Forum to see File Attachments
 
IP Logged
 
Visual Micro
Administrator
*****
Offline



Posts: 10895
United Kingdom
Re: Upload Error with Pololu A-Star Board
Reply #1 - Jan 31st, 2020 at 11:42am
 
Does it fail if you selected the No IDE option?

or if you add a local board.txt to the project with this in

Code:
upload.verify= 




It is important to follow the guide in yellow above and provide the build info when making these reports so that we can see what arduino version you have installed.




Back to top
« Last Edit: Jan 31st, 2020 at 11:43am by Visual Micro »  

Tim Leek
home
WWW  
IP Logged
 
wep
Newbies
*
Offline



Posts: 5
Re: Upload Error with Pololu A-Star Board
Reply #2 - Jan 31st, 2020 at 11:47am
 
Yes it does.  BTW, what happens when you choose NO IDE??
Back to top
 
 
IP Logged
 
Visual Micro
Administrator
*****
Offline



Posts: 10895
United Kingdom
Re: Upload Error with Pololu A-Star Board
Reply #3 - Jan 31st, 2020 at 12:00pm
 
Did you add the board.txt, click save, and build then try upload?
Back to top
 

Tim Leek
home
WWW  
IP Logged
 
wep
Newbies
*
Offline



Posts: 5
Re: Upload Error with Pololu A-Star Board
Reply #4 - Jan 31st, 2020 at 5:22pm
 
Hi Tim,
I just added that and it works!  Do you know what that is doing?  Not much of a directive...

Thanks!
Back to top
 
 
IP Logged
 
Visual Micro
Administrator
*****
Offline



Posts: 10895
United Kingdom
Re: Upload Error with Pololu A-Star Board
Reply #5 - Feb 6th, 2020 at 7:50pm
 
It's possible you are using an older version of visual micro with a newer pololu toolchain. They added the verify param to the upload command but they have not set a default value. This is why in the verbose upload command we could see an unresolved {variable} of {upload.verify}

You can always use the board.txt to override or apply properties but it's better to take the visual micro updates when available.

If you look at the vMicro>Uploader menu in recent visual micro versions you will see an option to enable "Verify" (after upload). If you also look at the verbose build properties after a build you will see "tools.avrdude.upload.params.noverify=-V". This means that we can fill the {upload.verify} with a -V to switch off verify. The "Verify" menu item in visual micro does just that if not enabled.

Therefore your upload might be faster if you modify the board.txt to this:-

Code:
upload.verify=-V 



You can also see in the verbose output where this is used to form the upload command:-

Code:
tools.avrdude.upload.pattern="{cmd.path}" "-C{config.path}" {upload.verbose} {upload.verify} -p{build.mcu} -c{upload.protocol} "-P{serial.port}" -b{upload.speed} -D "-Uflash:w:{build.path}/{build.project_name}.hex:i"
 



The {variables} and "patterns" are how all the arduino toolchains work and how visual micro knows what to do.
Back to top
« Last Edit: Feb 6th, 2020 at 8:00pm by Visual Micro »  

Tim Leek
home
WWW  
IP Logged
 
Page Index Toggle Pages: 1
Send Topic Print