Welcome, Guest. Please Login or Register
Arduino IDE for Visual Studio
 
 
When Logging a Support Issue in the Forum, please ensure you have also:-
  • Enabled vMicro > Compiler > Show Build Properties and Verbose
  • Re-Compile your program with these settings enabled
 
Save the new Output to a Text File and....
  • Click the Reply button and attach as .txt file OR
  • Click here to Email us with the file attached, and a link to your post
Support requests without the output above may be impossible to answer, so please help us to help you
 
  HomeSearch Tutorials & Wiki visualmicro.com LoginHelpRegister  
 
Page Index Toggle Pages: 1
Send Topic Print
Breakpoints cannot be added during debugging (Read 57 times)
arduino1
Junior Member
**
Offline



Posts: 74
Breakpoints cannot be added during debugging
Oct 16th, 2020 at 4:49pm
 
Though I had deleted a breakpoint being set prior to debugging, at line 26, it still stops at that line.
The breakpoint on line 28 is not being served.
Is there a fix for adding breakpoints during debug session?
Back to top
« Last Edit: Oct 16th, 2020 at 5:26pm by Visual Micro »  

Please Register or Login to the Forum to see File Attachments
 
IP Logged
 
Visual Micro
Administrator
*****
Offline



Posts: 10895
United Kingdom
Re: Breakpoints cannot be added during debugging
Reply #1 - Oct 16th, 2020 at 5:33pm
 
As explained previously the serial debugger injects debug commands in the temp build folder during build. Therefore if you make any breakpoint changes for the serial debugger config you need to compile and upload again.

Serial debugging is very different to hardware debugging. It is good practise to learn about each one by one then it is easier to be clear about the limitations and the features of each.

You will find some/different restirctions with each type of debugger for all microcontrollers regardless of IDE.

Thanks
Back to top
 

Tim Leek
home
WWW  
IP Logged
 
Page Index Toggle Pages: 1
Send Topic Print