Welcome, Guest. Please Login or Register
Arduino IDE for Visual Studio
 
 

Before logging an issue, please update to the latest release of Visual Micro from the Downloads Page.

When Logging a Support Issue in the Forum, please ensure you have also:-

  • Enabled vMicro > Compiler > Show Build Properties and Verbose
  • Re-Compile your program with these settings enabled
 
Save the new Output to a Text File and....
  • Click the Reply button and attach as .txt file OR
  • Click here to Email us with the file attached, and a link to your post
Support requests without the output above may be impossible to answer, so please help us to help you
 
  HomeSearch Tutorials & Wiki visualmicro.com LoginHelpRegister  
 
Page Index Toggle Pages: 1
Send Topic Print
"Active Code Has Priority Over Solution Explorer" no longer working (Read 994 times)
Ang
Newbies
*
Offline



Posts: 5
"Active Code Has Priority Over Solution Explorer" no longer working
Jun 29th, 2021 at 7:36am
 
I have a solution with two projects - one on ESP32 and another on Arduino Due.

Since the last update, bringing the active code in focus did not help select the active project. This happens even when the "Active Code Has Priority Over Solution Explorer" option is checked.

I had to manually "Set as Startup Project" for the correct project to compile.

Any ideas what could be the cause for this?

Thank you.

Back to top
 

Please Register or Login to the Forum to see File Attachments
 
IP Logged
 
Simon@Visual Micro
Administrator
*****
Offline



Posts: 1578
Re: "Active Code Has Priority Over Solution Explorer" no longer working
Reply #1 - Jun 29th, 2021 at 4:31pm
 
Thanks for the report.

Would it be possible to confirm what version of Visual Micro and Visual Studio you have installed as we are unable to reproduce this at present?
Back to top
 
 
IP Logged
 
Ang
Newbies
*
Offline



Posts: 5
Re: "Active Code Has Priority Over Solution Explorer" no longer working
Reply #2 - Jun 29th, 2021 at 11:47pm
 
Hi Simon

I'm using the following:
VS 2019 16.10.3
VM 19.0 build 2021.606.4

Thanks.

Edit:
I updated Visual Studio since my earlier post, and now the behaviour changed. It seems to detect the correct project when I select the active source file, but unless the project was set as startup project the vmicro toolbar disappears.

Once I set the project as startup project, the toolbar appears. It seems that if the project has been set as startup project at least once (since starting VS), this missing toolbar behaviour stops (for that project).

I appreciate your assistance.


Additional:

Code:
Microsoft Visual Studio Community 2019
Version 16.10.3
VisualStudio.16.Release/16.10.3+31424.327
Microsoft .NET Framework
Version 4.8.04084

Installed Version: Community

Visual C++ 2019   00435-60000-00000-AA190
Microsoft Visual C++ 2019

Arduino IDE for Visual Studio by Visual Micro   19.0
Visual Micro is an Arduino Compatible IDE for Visual Studio 2017-2019. For more information and forum please visit www.visualmicro.com.

ASP.NET and Web Tools 2019   16.10.526.50910
ASP.NET and Web Tools 2019

C# Tools   3.10.0-4.21318.11+7ceb633154acb9d716fd3eb2b6df1a0468d8e416
C# components used in the IDE. Depending on your project type and settings, a different version of the compiler may be used.

IntelliCode Extension   1.0
IntelliCode Visual Studio Extension Detailed Info

Linux Core Dump Debugging   1.0.9.31313
Enables debugging of Linux core dumps.

Microsoft JVM Debugger   1.0
Provides support for connecting the Visual Studio debugger to JDWP compatible Java Virtual Machines

Microsoft MI-Based Debugger   1.0
Provides support for connecting Visual Studio to MI compatible debuggers

Microsoft Visual C++ Wizards   1.0
Microsoft Visual C++ Wizards

Microsoft Visual Studio VC Package   1.0
Microsoft Visual Studio VC Package

NuGet Package Manager   5.10.0
NuGet Package Manager in Visual Studio. For more information about NuGet, visit https://docs.nuget.org/

ProjectServicesPackage Extension   1.0
ProjectServicesPackage Visual Studio Extension Detailed Info

Visual Basic Tools   3.10.0-4.21318.11+7ceb633154acb9d716fd3eb2b6df1a0468d8e416
Visual Basic components used in the IDE. Depending on your project type and settings, a different version of the compiler may be used.

Visual C++ for Linux Development   1.0.9.31313
Visual C++ for Linux Development

Visual Studio Code Debug Adapter Host Package   1.0
Interop layer for hosting Visual Studio Code debug adapters in Visual Studio

Visual Studio Tools for CMake   1.0
Visual Studio Tools for CMake 

Back to top
« Last Edit: Jun 30th, 2021 at 1:04am by Ang »  
 
IP Logged
 
Simon@Visual Micro
Administrator
*****
Offline



Posts: 1578
Re: "Active Code Has Priority Over Solution Explorer" no longer working
Reply #3 - Jun 30th, 2021 at 4:18pm
 
update: The release isnow in the Vs  Gallery

Thanks again for the detail around this.

The latest release 21.06.06.10 should resolve this issue, and it is available from the top of the board below:
https://www.visualmicro.com/forums/YaBB.pl?board=VS_ARDUINO_EXT_RELEASES

Back to top
« Last Edit: Jun 30th, 2021 at 5:42pm by Tim@Visual Micro »  
 
IP Logged
 
Ang
Newbies
*
Offline



Posts: 5
Re: "Active Code Has Priority Over Solution Explorer" no longer working
Reply #4 - Jul 1st, 2021 at 1:08am
 
The issue is resolved. Thank you very much. Smiley
Back to top
 
 
IP Logged
 
Page Index Toggle Pages: 1
Send Topic Print