Welcome, Guest. Please Login or Register
Arduino IDE for Visual Studio
 
 

Before logging an issue, please update to the latest release of Visual Micro from the Downloads Page.

When Logging a Support Issue in the Forum, please ensure you have also:-

  • Enabled vMicro > Compiler > Show Build Properties and Verbose
  • Re-Compile your program with these settings enabled
 
Save the new Output to a Text File and....
  • Click the Reply button and attach as .txt file OR
  • Click here to Email us with the file attached, and a link to your post
Support requests without the output above may be impossible to answer, so please help us to help you
 
  HomeSearch Tutorials & Wiki visualmicro.com LoginHelpRegister  
 
Page Index Toggle Pages: 1
Send Topic Print
Cannot change breakpoints after first debugging session in Visual Studio (Read 1889 times)
PMF
Newbies
*
Offline



Posts: 5
Cannot change breakpoints after first debugging session in Visual Studio
Nov 25th, 2021 at 6:29am
 
I'm using VSMicro in VS2019 with the serial debugger. Everything works fine before I start debugging for the first time. I can add breakpoints and/or tracepoints as expected. But after I end the debugging session (by clicking the "Stop" icon in the toolbar) I can no longer edit the breakpoints. All fields in the breakpoint properties (trace message, conditions) are grayed out and cannot be changed. This applies to existing breakpoints as well as new ones and is 100% reproducible.

Additionally, VS becomes partially unresponsive after this happens, e.g. files newly opened in the editor just open a black, empty window. The only solution is to restart Visual Studio after each debugging session.

The problem has been there since at least a year, but I only used VSMicro occassionally as debugger so far. Version currently used is 2021.1108.1904.
Back to top
 

Please Register or Login to the Forum to see File Attachments
 
IP Logged
 
Simon@Visual Micro
Administrator
*****
Offline



Posts: 1578
Re: Cannot change breakpoints after first debugging session in Visual Studio
Reply #1 - Nov 25th, 2021 at 10:00am
 
Thanks for the report.

Can you attach the build output with verbose and show build properties as shown in the box at the top of the page, so we can ensure we are reproducing your full environment?

Can you also attach the information as a text file, from Visual Studio > Help > About Microsoft Visual Studio > [Copy Info]?

Back to top
« Last Edit: Nov 25th, 2021 at 12:29pm by Simon@Visual Micro »  
 
IP Logged
 
PMF
Newbies
*
Offline



Posts: 5
Re: Cannot change breakpoints after first debugging session in Visual Studio
Reply #2 - Nov 27th, 2021 at 10:22am
 
@Simon I have attached the build output, but I don't think the problem is related to any build setting, because it happens irrespectively of any setting I see or the toolchain. The example is from an ESP32, but it happens for all boards I used (tested Arduino Uno and Arduino Due).

My suspicion is that it has something to do with culture settings or maybe the fact that I'm using a german version of Visual Studio.
Back to top
 

Please Register or Login to the Forum to see File Attachments
 
IP Logged
 
Tim@Visual Micro
Administrator
*****
Offline



Posts: 11542
United Kingdom
Re: Cannot change breakpoints after first debugging session in Visual Studio
Reply #3 - Nov 27th, 2021 at 4:27pm
 
Interesting info thanks.

Does your PC also have the default US language pack installed? (regardless of it being active)
Back to top
 

Tim Leek
home
WWW  
IP Logged
 
PMF
Newbies
*
Offline



Posts: 5
Re: Cannot change breakpoints after first debugging session in Visual Studio
Reply #4 - Nov 28th, 2021 at 11:46am
 
Yes, the language pack for "English (United States)" is installed. However, I'm using "German (Switzerland)" as my culture.
Back to top
 
 
IP Logged
 
Simon@Visual Micro
Administrator
*****
Offline



Posts: 1578
Re: Cannot change breakpoints after first debugging session in Visual Studio
Reply #5 - Nov 30th, 2021 at 4:12pm
 
Can you try the latest release (21.11.08-07), from the top of the board below to confirm if this improves the issue?
https://www.visualmicro.com/forums/YaBB.pl?board=VS_ARDUINO_EXT_RELEASES
Back to top
 
 
IP Logged
 
PMF
Newbies
*
Offline



Posts: 5
Re: Cannot change breakpoints after first debugging session in Visual Studio
Reply #6 - Dec 1st, 2021 at 7:35pm
 
Hey, wow! That really appears to have solved the issue. Great you were able to track this one down despite my quite vague assumption. I will need some more testing to finally confirm that everything now works as it should.
Back to top
 
 
IP Logged
 
Tim@Visual Micro
Administrator
*****
Offline



Posts: 11542
United Kingdom
Re: Cannot change breakpoints after first debugging session in Visual Studio
Reply #7 - Dec 1st, 2021 at 8:04pm
 
Great, thanks for the feedback. The problem really is that when sending numbers and dates as strings via serial US format will always be used. Therefore we use the number parsing of US culture for inbound serial debugger packets.

It's good to know the changes worked.

Back to top
« Last Edit: Dec 1st, 2021 at 8:05pm by Tim@Visual Micro »  

Tim Leek
home
WWW  
IP Logged
 
Page Index Toggle Pages: 1
Send Topic Print