Welcome, Guest. Please Login or Register
Arduino IDE for Visual Studio
 
 

Before logging an issue, please update to the latest release of Visual Micro from the Downloads Page.

When Logging a Support Issue in the Forum, please ensure you have also:-

  • Enabled vMicro > Compiler > Show Build Properties and Verbose
  • Re-Compile your program with these settings enabled
 
Save the new Output to a Text File and....
  • Click the Reply button and attach as .txt file OR
  • Click here to Email us with the file attached, and a link to your post
Support requests without the output above may be impossible to answer, so please help us to help you
 
  HomeSearch Tutorials & Wiki visualmicro.com LoginHelpRegister  
 
Page Index Toggle Pages: 1
Send Topic Print
Nano Every Debug Start Failing (GDB Stub) (Read 513 times)
Shadowcaster
Newbies
*
Offline



Posts: 3
Nano Every Debug Start Failing (GDB Stub)
Aug 13th, 2022 at 2:52pm
 
Just returning to play with Arduino for a small project. Installed fresh copy of VS22 (last project was on VS17). This time around I'm working with a Nano Every.

Turning on hardware debugging I get a Microsoft Visual Studio error message 'Unable to start debugging. Unexpected GDB output from command "-exec -run". Don't know how to run. Try "help target".

Sketch compiles fine, and serial debugger works.

Would much rather be able to use MS Studio internal functions such as watch.

Back to top
« Last Edit: Aug 13th, 2022 at 3:09pm by Tim@Visual Micro »  

Please Register or Login to the Forum to see File Attachments
 
IP Logged
 
Tim@Visual Micro
Administrator
*****
Offline



Posts: 11541
United Kingdom
Re: Nano Every Debug Start Failing (GDB Stub)
Reply #1 - Aug 13th, 2022 at 3:10pm
 
Thanks for the info.

1)
Have you added any code to your project for the GDB Stub? If so what have you added?

2)
Please show the verbose output after clicking the debug start or attach to process.

Thanks
Back to top
 

Tim Leek
home
WWW  
IP Logged
 
Shadowcaster
Newbies
*
Offline



Posts: 3
Re: Nano Every Debug Start Failing (GDB Stub)
Reply #2 - Aug 15th, 2022 at 1:46am
 
1) Nothing added for the GDB Stub

2) Can't find verbose option under vMicro->Debugger. Attaching standard debug window output.

Taking a step back my experience in the past was with VS17 i just installed Visual Micro and everything (call stack and watches native to VS worked so I'm out of my element here.
Back to top
 

Please Register or Login to the Forum to see File Attachments
 
IP Logged
 
Tim@Visual Micro
Administrator
*****
Offline



Posts: 11541
United Kingdom
Re: Nano Every Debug Start Failing (GDB Stub)
Reply #3 - Aug 15th, 2022 at 1:33pm
 
How to enable the verbose and the build properties is shown in the yellow box near the top of this page.

When you select the GDB Stub there is a hint that appears in the output window to show what is required to enable it. There hint is just the info from the git page of the GDb Stub library.

Did you see that? Can you review please. Normally for a stuf there is a command to put in setup() and possible one for the loop()

Thanks
Back to top
 

Tim Leek
home
WWW  
IP Logged
 
Simon@Visual Micro
Administrator
*****
Offline



Posts: 1578
Re: Nano Every Debug Start Failing (GDB Stub)
Reply #4 - Aug 17th, 2022 at 4:41pm
 
Just to update on this:

The ATMega4809 CPU which is on the Nano Every does not look to be currently compatible with the AVR-Debug Library referenced on our AVR and GDBStub page.

The Library page on GitHub for the AVR-Debug Library currently States:
Quote:
Works for Arduino Uno, Nano, Pro Mini (ATmega328), Arduino Mega, as well as for AtMega1284(P).


It does however appear you can construct a UPDI compatible programmer from a standard Arduino Nano/Uno, which can then sit between your Nano Every and your PC:
https://daumemo.com/diy-updi-usb-programmer-which-can-be-made-with-cheap-hardwar...

If you do either create or purchase a UPDI probe, we can assist in setting this up for use with Visual Micro, and then add this in to the default configurations in the future.
Back to top
 
 
IP Logged
 
Shadowcaster
Newbies
*
Offline



Posts: 3
Re: Nano Every Debug Start Failing (GDB Stub)
Reply #5 - Aug 18th, 2022 at 12:58am
 
Thanks so much for the information. Took awhile to find the hint that Tim pointed me to (didnt show up until the second time I switched to hardware debug). I suspected the library didn't support the Nano Every, just hadn't gotten that far yet. I may build the UDPI probe later as a project, if I do I'll reach back out. For now I've ordered a standard NANO that has the ATmega328 to do development from. 
Back to top
 
 
IP Logged
 
Page Index Toggle Pages: 1
Send Topic Print