Welcome, Guest. Please Login or Register
Arduino IDE for Visual Studio
 
 
When Logging a Support Issue in the Forum, please ensure you have also:-
  • Enabled vMicro > Compiler > Show Build Properties and Verbose
  • Re-Compile your program with these settings enabled
 
Save the new Output to a Text File and....
  • Click the Reply button and attach as .txt file OR
  • Click here to Email us with the file attached, and a link to your post
Support requests without the output above may be impossible to answer, so please help us to help you
 
  HomeSearch Tutorials & Wiki visualmicro.com LoginHelpRegister  
 
Page Index Toggle Pages: 1
Send Topic Print
ESP8266, {build.flash_ld} not expanding... (Read 6553 times)
rmathis
Junior Member
**
Offline



Posts: 13
ESP8266, {build.flash_ld} not expanding...
Oct 1st, 2015 at 4:29pm
 
When trying to build for Generic Esp8266 I'm getting error indicating that {build.flash_ld} and {build.flash_size} are not expanding. Possible others as well? But after hard coding these values in the platform.txt from the boards.txt file it seemed to work.

Question: what feature actually expands these <Macros?> is the linker or compiler or some feature in studio? Can I make changes to the project to resolve these issues?
Back to top
 

Please Register or Login to the Forum to see File Attachments
 
IP Logged
 
Visual Micro
Administrator
*****
Offline



Posts: 10707
United Kingdom
Re: ESP8266, {build.flash_ld} not expanding...
Reply #1 - Oct 1st, 2015 at 4:49pm
 
What is the board support url for the esp8266 that you installed?
Back to top
 

Please Register or Login to the Forum to see File Attachments
WWW  
IP Logged
 
rmathis
Junior Member
**
Offline



Posts: 13
Re: ESP8266, {build.flash_ld} not expanding...
Reply #2 - Oct 2nd, 2015 at 2:20pm
 
http://arduino.esp8266.com/staging/package_esp8266com_index.json

And I've notified igrr@esp8266/Arduino, who asked if it ran ok in the Arduino invironment, which it does. So he did not feel very concerned. But this features does make future builds a big hassle.
Back to top
 

Please Register or Login to the Forum to see File Attachments
 
IP Logged
 
Visual Micro
Administrator
*****
Offline



Posts: 10707
United Kingdom
Re: ESP8266, {build.flash_ld} not expanding...
Reply #3 - Oct 2nd, 2015 at 2:26pm
 
The esp firmware moves fast hence the reason they have different versions

I only look at them once every few months otherwise I wouldn't get anything else done. Unfortunately with the release of Visual Studio 2015 and this week Atmel 7 the work for new Ide's is more important.

I will catch up with the esp8266 when they release the next version

Did you try the published release from the official unofficial list

http://arduino.esp8266.com/stable/package_esp8266com_index.json

Thanks
Back to top
 

Please Register or Login to the Forum to see File Attachments
WWW  
IP Logged
 
Visual Micro
Administrator
*****
Offline



Posts: 10707
United Kingdom
Re: ESP8266, {build.flash_ld} not expanding...
Reply #4 - Oct 18th, 2015 at 9:42pm
 
Hi,

I've tried both the stable and the staging versions and they worked well for me.

I can see flash_size has resolved to "-bz 512K"

1)
These settings are automatically applied as a result of the board options menu items that you select via the Visual Micro menu. What did you selected or did you leave them on default?

2)
So that I can see your configuration please switch on "tools>options>visual micro>compiler>show build properties", also switch on "Verbose messages" then build and email the output to info[at]visualmicro.com

3)
Also confirm that you see all the board options on the Visual Micro menu?

Thanks
Back to top
« Last Edit: Oct 26th, 2015 at 11:57pm by Visual Micro »  

Please Register or Login to the Forum to see File Attachments
WWW  
IP Logged
 
Page Index Toggle Pages: 1
Send Topic Print