Welcome, Guest. Please Login or Register
Arduino IDE for Visual Studio
 
 
When Logging a Support Issue in the Forum, please ensure you have also:-
  • Enabled vMicro > Compiler > Show Build Properties and Verbose
  • Re-Compile your program with these settings enabled
 
Save the new Output to a Text File and....
Support requests without the output above may be impossible to answer, so please help us to help you
 
  HomeSearch Tutorials & Wiki visualmicro.com LoginHelpRegister  
 
Page Index Toggle Pages: 1
Send Topic Print
Issue with toolbar buttons (Read 850 times)
Arecon
Junior Member
**
Offline



Posts: 39
Issue with toolbar buttons
Oct 30th, 2018 at 9:41pm
 
Hi

I have noticed 2 issues with the toolbar buttons of Visualmicro:

1.
The button "Upload Last Build" doesn't work anymore since a couple of versions. It was claimed that this feature is now a Pro feature but it still doesn't work after buying and entering another license. It looks like the button is internally confused with another function. See screenshot 1 and 2.

2.
The button "Publish Server Data Files" that is claimed to upload project data to the data partition of an ESP32 is grayed out. I also don't really know how to use this feature. It seems to be undocumented.

Thanks for any clarification
Back to top
 

Scr1.PNG (20 KB | )
Scr1.PNG
Scr2.png (15 KB | )
Scr2.png
 
IP Logged
 
Arecon
Junior Member
**
Offline



Posts: 39
Re: Issue with toolbar buttons
Reply #1 - Oct 30th, 2018 at 9:43pm
 
Also I noticed that the tooltip text of the defective "Upload Last Build" button and the grayed out "Publish Server Data Files" are almost similar. Is this correct?
Back to top
 

Scr3.png (9 KB | )
Scr3.png
 
IP Logged
 
Visual Micro
Administrator
*****
Offline



Posts: 10142
United Kingdom
Re: Issue with toolbar buttons
Reply #2 - Oct 31st, 2018 at 1:01pm
 
Publish server data files will only be active when a esp board is selected.

Do these commands work from their original locations? for example vmicro>uploader
Back to top
 
WWW  
IP Logged
 
Arecon
Junior Member
**
Offline



Posts: 39
Re: Issue with toolbar buttons
Reply #3 - Oct 31st, 2018 at 3:02pm
 
Hi

The selected board is "ESP32 Dev Module".
"Upload last Build" works when started from the menu, the other feature has no menu entry.
Back to top
 
 
IP Logged
 
Visual Micro
Administrator
*****
Offline



Posts: 10142
United Kingdom
Re: Issue with toolbar buttons
Reply #4 - Nov 5th, 2018 at 3:40pm
 
"Publish Server Data Files" is only available for certain boards that support it and does not relate to any atmel or microchip hardware so should be used from visual studio as things currently stand
Back to top
 
WWW  
IP Logged
 
Arecon
Junior Member
**
Offline



Posts: 39
Re: Issue with toolbar buttons
Reply #5 - Nov 6th, 2018 at 5:59pm
 
I thought I posted this in the Atmel Studio sub-forum. Sorry. Maybe I was tired.
I now checked everything with Visual Studio 2017 and I can confirm that the "Publish Server Data Files(spiffs)" now is clickable.
Only the tooltip of the "Upload Last Build" button has the wrong text.
Back to top
« Last Edit: Nov 6th, 2018 at 6:00pm by Arecon »  
 
IP Logged
 
Visual Micro
Administrator
*****
Offline



Posts: 10142
United Kingdom
Re: Issue with toolbar buttons
Reply #6 - Nov 17th, 2018 at 4:58pm
 
Thanks very much. The tool tip has been updated for the next release.
Back to top
 
WWW  
IP Logged
 
Page Index Toggle Pages: 1
Send Topic Print